bugGNU Octave - Bugs: bug #56957, GCC error while compiling...

 
 

bug #56957: GCC error while compiling Octave4.4.1

Submitted by:  Harika Kotakonda <harika>
Submitted on:  Fri 27 Sep 2019 07:53:28 AM UTC  
 
Category:  Configuration and Build System Severity:  3 - Normal
Priority:  5 - Normal Item Group:  None
Status:  Need Info Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  4.4.1 Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Mon 30 Sep 2019 03:44:09 PM UTC, comment #7: 

If the original reporter is on a Debian-based system then

apt-get install build-essential

will install all the necessary tools to create executables from source code.

Also useful in this case is

apt-get build-dep octave

which will install all the necessary libraries to compile Octave.

Rik <rik5>
Project Administrator
Sun 29 Sep 2019 06:05:11 PM UTC, comment #6: 

I'm not expert in GCC nor C, but I do not think it is a bug with octave itself. It seems that your system is missing something.

I have just googled by "C compiler cannot create executables" (this error appears in the image you have attached) and most results suggest installing these packages:

1) g++
2) libc6-dev
3) glibc
4) make

In most cases it is enough.

best regards

Leonardo <pocker>
Fri 27 Sep 2019 04:03:31 PM UTC, comment #5: 

Octave version 4.4.1 is quite old and no longer supported.  The easiest thing to do would be to see if your distribution has a more recent version of Octave available as a package.

If you want to compile Octave from source code that is always possible, but you will need to make sure you have the correct tools and libraries installed before starting that process.  See this page for information about downloading Octave: https://www.gnu.org/software/octave/download.html.

Rik <rik5>
Project Administrator
Fri 27 Sep 2019 01:26:54 PM UTC, comment #4: 

can you please give me the download link for Octave 5.0. I would like to try this version.

Harika Kotakonda <harika>
Fri 27 Sep 2019 01:23:27 PM UTC, comment #3: 

Please find the attached log file

(file #47580)

Harika Kotakonda <harika>
Fri 27 Sep 2019 01:09:34 PM UTC, comment #2: 

@OP: We will need some info to determine the source of the failure.
As a stater, can you attach the config.log file that was generated in the build directory? Why not use the most recent tarball for Octave 5.1?

Pantxo Diribarne <pantxo>
Project Member
Fri 27 Sep 2019 07:53:28 AM UTC, comment #1: 

This item has been reassigned from the project Savannah Administration support tracker to your tracker.

The original report is still available at support #110035

Following are the information included in the original report:

[field #0]                  Item ID: 110035

[field #1]                 Group ID: 5802

[field #2]              Open/Closed: Open

[field #3]                 Severity: 4 - Important

[field #4]                  Privacy: Public

[field #8]                         : Unknown support Field Display Type

[field #9]                 Category: None

[field #10]             Submitted by: harika

[field #11]              Assigned to: None

[field #12]             Submitted on: Fri 27 Sep 2019 07:42:37 AM UTC

[field #13]                  Summary: GCC error while  compiling Octave4.4.1

[field #14]      Original Submission: Please refer attached image for error details.

What has been done:
Extracted the tar file
executed the command: ./configure --prefix=/root/Octave/Octave4.4.1

After executing this command , we receive the attached error. Seems C compiler doesn't work. Please help us to resolve the issue.
Please note theta we have installed GCC already in RHEL 7 server.

[field #16]               Item Group: None

[field #17]                   Status: None

[field #18]        Component Version: None

[field #19]         Operating System: GNU/Linux

[field #20]          Reproducibility: None

[field #21]               Size (loc): None

[field #22]            Fixed Release: None

[field #23]          Planned Release: None

[field #24]                   Effort: 0.00

[field #28]                 Priority: 5 - Normal

[field #31]         Percent Complete: 0%

[field #33]                  Release: None

[field #36]         Originator Email: hkota@equinor.com

[field #58]     Custom Select Box #1: None

[field #59]     Custom Select Box #2: None

[field #60]     Custom Select Box #3: None

[field #61]     Custom Select Box #4: None

[field #62]     Custom Select Box #5: None

[field #63]     Custom Select Box #6: None

[field #64]     Custom Select Box #7: None

[field #65]     Custom Select Box #8: None

[field #66]     Custom Select Box #9: None

[field #67]    Custom Select Box #10: None

Ineiev <ineiev>
Fri 27 Sep 2019 07:53:28 AM UTC, original submission:  

Please refer attached image for error details.

What has been done:
Extracted the tar file
executed the command: ./configure --prefix=/root/Octave/Octave4.4.1

After executing this command , we receive the attached error. Seems C compiler doesn't work. Please help us to resolve the issue.
Please note theta we have installed GCC already in RHEL 7 server.

Harika Kotakonda <harika>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #47580:  conf.txt added by harika (40KiB - text/plain)
file #47578:  1.png added by harika (271KiB - image/png)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by pocker (Posted a comment)
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by pantxo (Posted a comment)
  • -email is unavailable- added by harika (Submitted the item)
  • -email is unavailable- added by harika
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 8 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-10-04 rik5 Open/ClosedOpen => Closed
    2019-09-27 harika Attached File- => Added conf.txt, #47580
    2019-09-27 pantxo CategoryNone => Configuration and Build System
        Severity4 - Important => 3 - Normal
        StatusNone => Need Info
        ReleaseNone => 4.4.1
        Operating SystemNone => GNU/Linux
    2019-09-27 ineiev Reassign itemSavannah Administration, sr #110035 => GNU Octave, bug #56957

    Back to the top


    Powered by Savane 3.5