bugGNU Octave - Bugs: bug #56865, Variable editor widget does not...

 
 

bug #56865: Variable editor widget does not resize

Submitted by:  Henk Borsje <hjborsje>
Submitted on:  Sat 07 Sep 2019 07:48:44 AM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Other
Status:  Duplicate Assigned to:  None
Originator Name:  Henk Borsje Open/Closed:  Closed
Release:  5.1.0 Operating System:  Microsoft Windows

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Tue 10 Sep 2019 01:23:03 AM UTC, comment #4: 

From the OP I conclude that floating subpanes can not be resized, thus marking this bug as duplicate of bug #55048.

Torsten Lilge <ttl>
Project Member
Sat 07 Sep 2019 07:23:00 PM UTC, comment #3: 

I recognize the missing cursor feedback but then from from undocked VE subpanes, not the entire VE pane. The tolerance margin is still a few pixels on the subpanes.

Do we refer to the same thing, "widgets" and "subpanes" ?

-Philip

Anonymous
Sat 07 Sep 2019 11:54:23 AM UTC, comment #2: 

I'm using Windows 10 release 1803.

Actually, my previous comment was incorrect, it is possible to resize the widgets, but only by putting the cursor exactly on the edge of the window, there is no margin of tolerance.  There is never any feedback from the cursor, so it is not obvious to see when resizing is active.
I can undock the whole VE and resize that window as expected.

Henk Borsje <hjborsje>
Sat 07 Sep 2019 10:31:15 AM UTC, comment #1: 

<_Philip here / trouble logging in_>

With a 5.1.1 build dating from end of February and yesterday's 6.0.0 (cross)build I cannot reproduce that.

It is known [*] that under Windows, undocked VE subpanes (undocked from the VE pane itself) lack window decoration and resizing is more difficult if not impossible. Are you sure you're talking about the complete VE pane rather than a subpane?

Do you have the latest Win10 feature update (1903) installed? Here I still have 1809.  Win10's feature updates are known to occasionally break things.

[*] (I can't search "My Items" due to login issues here) This has been reported but maybe in the scope of a related bug report.

Anonymous
Sat 07 Sep 2019 07:48:44 AM UTC, original submission:  

I don't know if this is a bug or a missing feature.  When I undock one array window from the variable editor I expect that I can resize the undocked widget. On my laptop (Windows 10) it is not possible to resize the widget. It is possible to adjust the width and height of rows and columns.  I don't have an older version available, but if my memory serves me right this resizing was possible in the past.

Henk B

Henk Borsje <hjborsje>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by ttl (Posted a comment)
  • -email is unavailable- added by hjborsje (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-09-10 ttl Dependencies- => Depends on bugs #55048
    2019-09-10 ttl StatusNone => Duplicate
        Open/ClosedOpen => Closed

    Back to the top


    Powered by Savane 3.5