bugGNU Octave - Bugs: bug #56604, Interpreter gets confused by ...

 
 

bug #56604: Interpreter gets confused by <********

Submitted by:  Doug Stewart <dastew>
Submitted on:  Wed 10 Jul 2019 01:21:56 PM UTC  
 
Category:  Interpreter Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Unexpected Error
Status:  Invalid Assigned to:  None
Originator Name:  Doug Stewart Open/Closed:  Closed
Release:  5.1.0 Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Wed 10 Jul 2019 08:24:57 PM UTC, comment #7: 

OK please close this as invalid.

Doug Stewart <dastew>
Wed 10 Jul 2019 08:10:56 PM UTC, comment #6: 

It does not try to run the file. The syntax error message that you see comes from the 'dbstop' function. In order to set a breakpoint, the debug functions are trying to access the parse tree, which probably triggers the parser to try to load the file again, since it hasn't been successfully loaded yet, but not run it.

Mike Miller <mtmiller>
Project Administrator
Wed 10 Jul 2019 07:43:28 PM UTC, comment #5: 

I just thought it should not try to rerun the file.

Doug Stewart <dastew>
Wed 10 Jul 2019 06:40:28 PM UTC, comment #4: 

You might be interested in open bug #48082, which seems to be about supporting breakpoints in files that can't be parsed.

Mike Miller <mtmiller>
Project Administrator
Wed 10 Jul 2019 06:31:19 PM UTC, comment #3: 

My point is I don't see a bug, so I would close this as working correctly.

What do you think the bug is? Should the editor pop up a message or something to tell the user why a breakpoint can't be set instead of relying on the command window to tell why? Or what other different behavior is needed?

Mike Miller <mtmiller>
Project Administrator
Wed 10 Jul 2019 06:28:21 PM UTC, comment #2: 

OK I think you understand it better than I do.
Please reword it better.

Doug Stewart <dastew>
Wed 10 Jul 2019 06:21:05 PM UTC, comment #1: 

I don't see Octave getting stuck at all. Can you explain better what that looks like or what you think is stuck?

What I observe is that the script reports a syntax error when Octave is asked to run it or debug it. If the editor is used to try to place a breakpoint, the syntax error is reported again, and the breakpoint isn't set. Everything in Octave continues working normally.

Mike Miller <mtmiller>
Project Administrator
Wed 10 Jul 2019 01:21:56 PM UTC, original submission:  

I was trying to help a person with their code and I ran into this problem.

Run this code in the GUI default editor.
You will get an error message.
Now with the mouse try and add a breakpoint in the editor.
When you click to add the breakpoint then Octave runs the code again and reports the error again

I tried many ways to get it out of this mode, but in the end I had to restart octave

I know where the problem is  but octave should not get stuck like it does.


n=5
s=[2 0;1 1;1 3],
b=[0 -1 0];
center_x=1;
center_y=0;
circle_count=(s(1,1)+s(1,2))/2
Right_connector=zeros(19,4); <*****
Left_connector=zeros(19,4);
connector_index =1;

Doug Stewart <dastew>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Updated the item)
  • -email is unavailable- added by dastew (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-07-10 rik5 StatusWorks For Me => Invalid
        Open/ClosedOpen => Closed
    2019-07-10 mtmiller StatusNone => Works For Me

    Back to the top


    Powered by Savane 3.5