bugGNU Octave - Bugs: bug #56009, [octave forge] (database)...

 
 

bug #56009: [octave forge] (database) '__pq_connect__' undefined in Octave 5.1.0 with 'database' package 2.4.3

Submitted by:  Dennis B <jarringjigger>
Submitted on:  Wed 27 Mar 2019 03:00:29 PM UTC  
 
Category:  Octave Forge Package Severity:  3 - Normal
Priority:  5 - Normal Item Group:  None
Status:  Invalid Assigned to:  None
Originator Name:  JarringJigger Open/Closed:  Closed
Release:  5.1.0 Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 01 Apr 2019 12:03:44 PM UTC, comment #5: 

Thanks a lot for your support and for pointing me to the new release (candidate).
The database 2.4.4 tarball installed fine in Octave 5.1.0, connecting to and querying the db is now working for me with this combination.
Thanks!

Dennis B <jarringjigger>
Mon 01 Apr 2019 10:22:42 AM UTC, comment #4: 

There is a new version of database that is in process of being released that will install in 5.1 [1]

It has to be compiled for the version of octave that is being used which is why the old octave version isnt working on 5.1

[1] https://sourceforge.net/p/octave/package-releases/372/

John Donoghue <lostbard>
Project Member
Mon 01 Apr 2019 09:21:27 AM UTC, comment #3: 

The attempt to reinstall the database package under Octave 5.1.0- 4 failed with the following error(s):

octave> pkg install -forge database
error-helpers.cc: In Funktion »void _p_error(const char*, ...)«:
error-helpers.cc:53:40: Warnung: »size_t octave_vformat(std::ostream&, const char*, __va_list_tag*)« ist veraltet: [5]: use 'octave::vformat' instead [-Wdeprecated-declarations]
   octave_vformat (output_buf, fmt, args);
                                        ^
In file included from /usr/include/octave-5.1.0/octave/../octave/oct.h:38,
                 from error-helpers.cc:20:
/usr/include/octave-5.1.0/octave/../octave/utils.h:238:1: Anmerkung: hier deklariert
octave_vformat (std::ostream& os, const char *fmt, va_list args);
^~~~~~~~~~~~~~
error-helpers.cc:53:40: Warnung: »size_t octave_vformat(std::ostream&, const char*, __va_list_tag*)« ist veraltet: [5]: use 'octave::vformat' instead [-Wdeprecated-declarations]
   octave_vformat (output_buf, fmt, args);
                                        ^
In file included from /usr/include/octave-5.1.0/octave/../octave/oct.h:38,
                 from error-helpers.cc:20:
/usr/include/octave-5.1.0/octave/../octave/utils.h:238:1: Anmerkung: hier deklariert
octave_vformat (std::ostream& os, const char *fmt, va_list args);
^~~~~~~~~~~~~~
error-helpers.cc:60:8: Fehler: »cerr« ist kein Element von »std«
   std::cerr << msg;
        ^~~~
error-helpers.cc:60:8: Anmerkung: »std::cerr« ist im Header »<iostream>« definiert; haben Sie vergessen, »#include <iostream>« zu schreiben?
error-helpers.cc:23:1:
+#include <iostream>

error-helpers.cc:60:8:
   std::cerr << msg;
        ^~~~
make: *** [Makefile:92: error-helpers.o] Fehler 1
make: *** Es wird auf noch nicht beendete Prozesse gewartet....
make: Verzeichnis „/tmp/oct-w7Yl7Y/database-2.4.3/src“ wird betreten
CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" /usr/bin/mkoctfile-5.1.0 -I`pg_config --includedir` -c __pq_connect__.cc
CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" /usr/bin/mkoctfile-5.1.0 -I`pg_config --includedir` -c pq_close.cc
CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" /usr/bin/mkoctfile-5.1.0 -I`pg_config --includedir` -c pq_exec.cc
CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" /usr/bin/mkoctfile-5.1.0 -I`pg_config --includedir` -c converters.cc
CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" /usr/bin/mkoctfile-5.1.0 -I`pg_config --includedir` -c converters_arr_comp.cc
CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" /usr/bin/mkoctfile-5.1.0 -I`pg_config --includedir` -c pq_connection.cc
CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" /usr/bin/mkoctfile-5.1.0 -I`pg_config --includedir` -c command.cc
CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" /usr/bin/mkoctfile-5.1.0 -I`pg_config --includedir` -c pq_update_types.cc
CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" /usr/bin/mkoctfile-5.1.0 -I`pg_config --includedir` -c pq_lo.cc
CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" /usr/bin/mkoctfile-5.1.0 -I`pg_config --includedir` -c pq_conninfo.cc
CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" /usr/bin/mkoctfile-5.1.0 -I`pg_config --includedir` -c __pq_internal_exit__.cc
CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" /usr/bin/mkoctfile-5.1.0 -c error-helpers.cc
CXXFLAGS="-march=x86-64 -mtune=generic -O2 -pipe -fstack-protector-strong -fno-plt" /usr/bin/mkoctfile-5.1.0 -I`pg_config --includedir` -c var2bytea.cc
rm var2bytea.o
make: Verzeichnis „/tmp/oct-w7Yl7Y/database-2.4.3/src“ wird verlassen

pkg: error running `make' for the database package.
error: called from
    configure_make at line 99 column 9
    install at line 184 column 7
    pkg at line 441 column 9

After downgrading Octave to version 4.4.1-7, the database package  installed without any issues and works properly.
In Octave 5.1.0 the previously reported error remains after reinstalling the database package in Octave 4.4.1-7 and then switching back to Octave 5.1.0.

Dennis B <jarringjigger>
Thu 28 Mar 2019 07:45:05 PM UTC, comment #2: 

I didn't, thanks for the hint.
Unfortunately, I cannot test it before Monday, but I can well imagine this will resolve the issue already...
I'll post an update next Monday.

Dennis B <jarringjigger>
Wed 27 Mar 2019 04:26:13 PM UTC, comment #1: 

Did you reinstall the database package for the new version of octave ?

John Donoghue <lostbard>
Project Member
Wed 27 Mar 2019 03:00:29 PM UTC, original submission:  

When calling 'pq_connect(...)' from within a previously existing and working script file I get the following error message after updating from Octave 4.4.1-7 to 5.1.0-2 under Manjaro Linux 18.0.4:

error: '__pq_connect__' undefined near line 112 column 10
error: called from
    pq_connect at line 112 column 8

The server to connect with is a PostgreSQL 9.5, connecting via pgAdmin is working properly. I am using 'database' package version 2.4.3.
Can someone confirm or, even better, guide me how to fix this?

Dennis B <jarringjigger>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by lostbard (Posted a comment)
  • -email is unavailable- added by jarringjigger (Submitted the item)
  • -email is unavailable- added by jarringjigger (compatibility issue of 'database' 2.4.3 with Octave 5.1.0?)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-04-01 mtmiller StatusNone => Invalid
        Open/ClosedOpen => Closed
    2019-03-27 jarringjigger Carbon-Copy- => Added i7tiol

    Back to the top


    Powered by Savane 3.5