bugGNU Octave - Bugs: bug #55431, Figure window (qt) can't be closed...

 
 

bug #55431: Figure window (qt) can't be closed in a loop and trying to do so crashes Octave after Ctrl-C

Submitter:  Lars Kindermann <larskindermann>
Submitted:  Wed 09 Jan 2019 11:41:37 PM UTC
 
Category:  Plotting with OpenGL Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Segfault, Bus Error, etc.
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  * Closed
Release:  * 5.0.1 Operating System:  * GNU/Linux
Fixed Release:  None Planned Release:  None
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Thu 10 Jan 2019 09:18:35 AM UTC, comment #5: 

I can confirm that this is a duplicate of bug #54187 and that the patch there also fixes the test case from comment #0. Closing this report as a duplicate.

Pantxo Diribarne <pantxo>
Project Member
Thu 10 Jan 2019 05:16:23 AM UTC, comment #4: 

A brief summary:

for "octave >= 4.4.0" and "graphics_toolkit == qt":

while running some code, before returning to the octave prompt,
using the menu File->Close (or clicking the Close Window button) has no effect,

and
if doing this more than once, then it will crash with segfault
after returning to the octave prompt.

Anonymous
Thu 10 Jan 2019 04:45:40 AM UTC, comment #3: 

@Rik:
Hi, this is a duplication of bug #54187,
and in bug #54187 some patches have already been submitted and tested by some developers recently, which may be useful and helpful.

Anonymous
Thu 10 Jan 2019 02:42:07 AM UTC, comment #2: 

Confirmed, but only with qt toolkit.  FLTK is fine.

For a definitive segfault, instead of Ctrl+C, try using the menu File->Close.

For a definitive segfault, Click the Close Window button once, then go over and use File->Close.

This seems like a race condition because if I execute the commands individually they run fine.

Rik <rik5>
Project Administrator
Thu 10 Jan 2019 02:16:09 AM UTC, comment #1: 

This bug is a regression from Octave 4.4; see also bug #54187

Earlier version (4.2.x, 4.0.x, ...) does not have this bug.

Anonymous
Wed 09 Jan 2019 11:41:37 PM UTC, original submission:  

In MATLAB I frequently used a construct like this:

figure(1)
while isfigure(1)
 data=rand(100,1);
 plot(data);
 drawnow
 pause(1)
end

 

Closing the figure window should terminate the loop.

But in Octave clicking the close button seems to have no effect.

But afterwards, when terminating the loop with Ctrl-C, Octave immediately crashes with a segfault.

Lars Kindermann <larskindermann>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by pantxo (Posted a comment)
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by larskindermann (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 6 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-01-10 pantxo Open/ClosedOpen Closed
    2019-01-10 pantxo StatusConfirmed Duplicate
        Dependencies- Depends on bugs #54187
    2019-01-10 rik5 CategoryPlotting Plotting with OpenGL
        StatusNone Confirmed
        SummaryFigure window cannot be closed in a loop and trying to do so crashes Octave after Ctrl-C Figure window (qt) can't be closed in a loop and trying to do so crashes Octave after Ctrl-C

    Back to the top


    Powered by Savane 3.9