bugGNU Octave - Bugs: bug #53874, doc_cache_create doesnt handle...

 
 

bug #53874: doc_cache_create doesnt handle classdef documentation

Submitted by:  John Donoghue <lostbard>
Submitted on:  Thu 10 May 2018 08:37:11 PM UTC
 
Category:  Octave Function Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Inaccurate Result
Status:  Duplicate Assigned to:  None
Originator Name:  JohnD Open/Closed:  * Closed
Release:  * 4.4.0 Operating System:  * Any
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Tue 01 Dec 2020 04:55:23 PM UTC, comment #5: 

Closing as a duplicate of bug #43047.

Markus M├╝tzel <mmuetzel>
Project Member
Mon 04 Mar 2019 06:36:40 AM UTC, comment #4: 

Yes, looks like bug #43047

I was stumbling over this because I wanted to implement VideoReader and VideoWriter for the octave-forge video package

Andreas Weber <andy1978>
Project Member
Thu 05 Jul 2018 09:01:08 PM UTC, comment #3: 

In addition any functions defined within the classdef both in the classdef file, and in @classname/functionX.m do not register for help, unlike older class functions.

John Donoghue <lostbard>
Project Member
Thu 05 Jul 2018 07:47:25 PM UTC, comment #2: 

Although more specifically could deal with packages etc, where the help will not appear through help or doc, nor be included in generated docs from generate_html

John Donoghue <lostbard>
Project Member
Sun 20 May 2018 12:40:25 PM UTC, comment #1: 

I guess is a duplicate of #43047

John Donoghue <lostbard>
Project Member
Thu 10 May 2018 08:37:11 PM UTC, original submission:  

There doesn't seem to be anyway for classdef files to have help documentation.

Any texinfo documentation in the file does not appear to get used, giving a warning message of doc_cache_create: unusable help text found in file

John Donoghue <lostbard>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mmuetzel (Posted a comment)
  • -email is unavailable- added by andy1978 (Posted a comment)
  • -email is unavailable- added by lostbard (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2020-12-01 mmuetzel StatusNone => Duplicate
        Open/ClosedOpen => Closed
        Dependencies- => Depends on bugs #43047

    Back to the top


    Powered by Savane 3.9