bugGNU Octave - Bugs: bug #53436, position and scaling wrong in...

 
 

bug #53436: position and scaling wrong in plot-function

Submitter:  Hans <alzi123>
Submitted:  Fri 23 Mar 2018 06:43:49 AM UTC
 
Category:  Plotting Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Unexpected Error or Warning
Status:  Duplicate Assigned to:  None
Originator Name:  alzi123 Open/Closed:  * Closed
Release:  * 4.2.0 Operating System:  * Microsoft Windows
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Fri 23 Mar 2018 06:49:59 AM UTC, comment #1: 

Thanks for the test case and the bug report. This is actually a well known issue with Octave's default OpenGL plotting toolkit.

If you want a workaround for this behavior, try using the gnuplot toolkit:

>> graphics_toolkit gnuplot

I am closing this bug report as a duplicate of bug #32980.

Mike Miller <mtmiller>
Project Administrator
Fri 23 Mar 2018 06:43:49 AM UTC, original submission:  

Try this ...

axis are displayed as horizontal line only:
y=1E8+rand(1,100); plot(y);

the position of the plot is totally out of the center position:
y=1E7+rand(1,100); plot(y);

I noticed this behaviour dealing with the datenum function which gives vectors with huge offsets and small differences.

Hans <alzi123>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by alzi123 (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-03-23 mtmiller StatusNone Duplicate
        Open/ClosedOpen Closed
        Dependencies- Depends on bugs #32980

    Back to the top


    Powered by Savane 3.9