bugGNU Octave - Bugs: bug #52910, Multi line comments should have...

 
 

bug #52910: Multi line comments should have added asterisk in each line to increase readability.

Submitted by:  Dildar Sk <hodor123456>
Submitted on:  Tue 16 Jan 2018 10:31:07 AM UTC  
 
Category:  Documentation Severity:  1 - Wish
Priority:  3 - Low Item Group:  Feature Request
Status:  Invalid Assigned to:  None
Originator Name:  Dildar Sk Open/Closed:  Closed
Release:  4.2.1 Operating System:  Any

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Wed 17 Jan 2018 07:37:20 PM UTC, comment #7: 

Comment #4 was an accidental post to this report, unrelated.

I think if there are true consistency problems with the comment blocks in Octave source files, then they can be fixed, but I haven't seen any yet after some brief looking around.

Dildar - we are not shutting you down, but I am going to close this bug since there is nothing to act on at the moment. Please do feel free to study Octave's source files, and do report any bugs or consistency problems that you find, preferably with patches.

Octave's source files are the ones in the mercurial repository, listed with the "hg files" command for example. Some of these files are also pulled from other projects, so we might be intentionally preserving a different style in a few files to keep the source as close to the original as possible (e.g. kpse, oct-sort, Faddeeva).

Mike Miller <mtmiller>
Project Administrator
Wed 17 Jan 2018 07:03:37 PM UTC, comment #6: 

There is already a bug report about unicode file name handling:  bug #49118

We are not changing the comment style in Octave sources.

John W. Eaton <jwe>
Project Administrator
Wed 17 Jan 2018 10:22:06 AM UTC, comment #5: 

Then what are octave source files?
I will study them.

Dildar Sk <hodor123456>
Wed 17 Jan 2018 05:20:08 AM UTC, comment #4: 

Well, it does not look like an API misuse in the GUI binary.
Windows GUI shell opens "unicoded" filenames without questions.

It seems to me, the problem is in interpreter. It looks like standard path/name handling in such functions as cd(), or readcvs/dlm do not  handle, or do not allow handling strings (probably corrupting them) as Unicode when passing to Windows system.

You see, "TESTテスト①.csv" looks like exact 8-bit conversion of "TESTテスト①.csv", so there is no data corruption, only data-type is undetermined in Ocave, since there is no UTF-char type.
However, (AFAIK) WinAPI functions expect the data in specific format for further handling. And I foresee three possibilities:
1)Octave cripples the string with precaution procedures when passing it to WinAPI. I.e. like truncating or extending the string basing on difference in byte/character count. Or replacing "unknown" bytes with "?"...
2)Octave misuses WinAPI, calling obsolete functions(like winapi OpenFile, fopen instead of _wfopen)

Anonymous
Tue 16 Jan 2018 06:05:31 PM UTC, comment #3: 

No it is not an Octave source file, it is imported from gnulib.

Any other files affected?

Mike Miller <mtmiller>
Project Administrator
Tue 16 Jan 2018 05:35:18 PM UTC, comment #2: 

Is not octave/libgnu/glthread/lock.h octave source file?Whatever,I did not mean anything unreadable.I meant that adding asterisk in start of each line in multi line comment would increase readability.

Dildar Sk <hodor123456>
Tue 16 Jan 2018 05:24:14 PM UTC, comment #1: 

The screenshot attached to this bug report is not an Octave source file.

Octave source files are mostly C++ and mostly use C++ //-style comments, with the exception of the standard license file header.

In short, I don't see anything here that needs fixing. Can you give an example of a file with an unreadable block comment?

Mike Miller <mtmiller>
Project Administrator
Tue 16 Jan 2018 10:31:07 AM UTC, original submission:  

This is not a bug,just a suggestion.I think in multi line comments,in the start of each line a asterisk should have added.I find it increasing readability.In some .c,.h code I found long comments which would be better with added asterisk.

Dildar Sk <hodor123456>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #42923:  long comments.png added by hodor123456 (125KiB - image/png)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by jwe (Posted a comment)
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by hodor123456 (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 7 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-01-17 mtmiller StatusNone => Invalid
        Open/ClosedOpen => Closed
    2018-01-16 rik5 Carbon-CopyRemoved 72865 => -
    2018-01-16 rik5 Severity3 - Normal => 1 - Wish
        Priority5 - Normal => 3 - Low
    2018-01-16 rik5 Item GroupOther => Feature Request
    2018-01-16 hodor123456 Attached File- => Added long comments.png, #42923

    Back to the top


    Powered by Savane 3.5