bugGNU Octave - Bugs: bug #49646, Segmentation fault after a caught...

 
 

bug #49646: Segmentation fault after a caught error in an Octave script

Submitter:  Guillaume <gyom>
Submitted:  Fri 18 Nov 2016 05:21:40 PM UTC
   
 
Category:  Interpreter Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Segfault, Bus Error, etc.
Status:  Duplicate Assigned to:  None
Originator Name:  Guillaume Open/Closed:  * Closed
Release:  * dev Operating System:  * GNU/Linux
Fixed Release:  None Planned Release:  None
* Mandatory Fields

Add a New Comment Rich Markup
   

Fri 18 Nov 2016 06:24:19 PM UTC, comment #2: 

Can I close this report since it is a duplicate?

Rik <rik5>
Group administrator
Fri 18 Nov 2016 05:32:24 PM UTC, comment #1: 

Sorry, it's actually a duplicate of bug #49271 and still happens without the caught error.

Guillaume <gyom>
Fri 18 Nov 2016 05:21:40 PM UTC, original submission:  

if you execute the following script:


#!/usr/bin/octave

try
  error ("error")
end

exit (1);


you get:


./test_octave.sh
terminate called after throwing an instance of 'octave::exit_exception'
panic: Aborted -- stopping myself...
attempting to save variables to 'octave-workspace'...
save to 'octave-workspace' complete
octave exited with signal 6


Guillaume <gyom>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Updated the item)
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by gyom (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only group members can vote.

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-11-18 mtmiller StatusNone Duplicate
        Open/ClosedOpen Closed
        Dependencies- Depends on bugs #49271

    Back to the top

    Powered by Savane 3.13-4b48.
    Corresponding source code