bugGNU Octave - Bugs: bug #48514, dev version: two failing tests on...

 
 

bug #48514: dev version: two failing tests on Ubuntu 14.04 (sparse and realpow)

Submitter:  Hartmut <hardy>
Submitted:  Thu 14 Jul 2016 06:11:44 PM UTC
   
 
Category:  Octave Function Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Regression
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  * Closed
Release:  * dev Operating System:  * Any
Fixed Release:  None Planned Release:  None
* Mandatory Fields

Add a New Comment Rich Markup
   

Jump to the original submission

Fri 15 Jul 2016 11:45:44 AM UTC, comment #7: 

Closing as requested.

Lachlan Andrew <lachlan>
Fri 15 Jul 2016 11:33:32 AM UTC, comment #6: 

I used gcc 4.8.2. for my compilation. This means that my observed behavior is only a duplicate of bug #47775. There, it was decided to not fix it, but to use a newer gcc version instead.

So please close this bug report.

Hartmut <hardy>
Fri 15 Jul 2016 09:44:36 AM UTC, comment #5: 

sorry, bug #47775

Anonymous
Fri 15 Jul 2016 09:42:02 AM UTC, comment #4: 

Is it duplicate of byg#47775?

Anonymous
Fri 15 Jul 2016 06:54:01 AM UTC, comment #3: 

 What's the gcc version?

Anonymous
Thu 14 Jul 2016 06:53:36 PM UTC, comment #2: 

This is a 64bit Ubuntu 14.04. (Let me know what linux commands to run to maybe get more detailed information on my machine.)

Hartmut <hardy>
Thu 14 Jul 2016 06:49:09 PM UTC, comment #1: 

Is this x86 (32 bit) or x86_64 (64 bit) built?

Dmitri.
--

Dmitri A. Sergatskov <dasergatskov>
Thu 14 Jul 2016 06:11:44 PM UTC, original submission:  

I have used the code from the "default" code line in the Octave repository, last hg commmit was "4c0f78b3c86f".

When I compile on Ubuntu 14.04 (./configure --disable-docs to avoid compiling problems with osmesa), then I get two failing test:


***** assert (sparse (2i) .^ [3, 4], sparse ([-0-8i, 16]))
!!!!! test failed
ASSERT errors for:  assert (sparse (2i) .^ [3, 4],sparse ([-0 - 8i, 16]))

  Location  |  Observed  |  Expected  |  Reason
    (1)      -1.46958e-15-8i     0-8i       Abs err 2.3054e-15 exceeds tol 0
    (2)      16-3.91887e-15i    16+0i       Abs err 4.3027e-15 exceeds tol 0



>>>>> processing /home/hartmut-nobackup/octave-repo/scripts/specfun/realpow.m
***** assert (realpow (1i,2), -1)
!!!!! test failed
realpow: produced complex result



(And additionally two osmesa related test fail, but that seems to be known and is due to a buggy osmesa version in Ubuntu 14.04.)

Are those two failing test also known, or is there something wrong?

Hartmut <hardy>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by lachlan (Posted a comment)
  • -email is unavailable- added by dasergatskov (Posted a comment)
  • -email is unavailable- added by hardy (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only group members can vote.

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-07-15 lachlan StatusNone Duplicate
        Open/ClosedOpen Closed

    Back to the top

    Powered by Savane 3.13-ee12.
    Corresponding source code