bugGNU Octave - Bugs: bug #48197, Octave hangs when plot function...

 
 

bug #48197: Octave hangs when plot function invoked on command line

Submitted by:  None
Submitted on:  Fri 10 Jun 2016 06:41:35 PM UTC  
 
Category:  Plotting with OpenGL Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  Invalid Assigned to:  None
Originator Name:  David O'Brien Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  4.0.2
Operating System:  Mac OS

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Fri 17 Jun 2016 10:35:28 PM UTC, comment #5: 

Hello,

I was able to work around the problem with default qt plotting by setting
"graphics_toolkit gnuplot" and installing gnuplot with the Aquaterm option.
I also added a fontconfig path to my terminal bash shell profile per the first answer to the question posed in the following following link
http://stackoverflow.com/questions/35249881/octave-fontconfig-error
(Working on a Mac OS X El Capitan).   This worked fine.

Today I checked again and set "graphics_toolkit qt" and ran my program.  It worked fine and also plotting from the command line window also worked (previously had hung on every attempt).   Perhaps the fontconfig resolution fixed the problem, or when I installed gnuplot with Aquaterm some needed dependency file got included?   I don't believe I am using "debug_on_error(1)".  In any case since I cannot reproduce the bug I think it is OK to close it.

Thanks for following up.   Best regards,  David.

David O'Brien <dobrien16>
Fri 17 Jun 2016 02:02:58 AM UTC, comment #4: 

David, this is a long shot, but do you use "debug_on_error(1)" by any chance?  If so, you might be running into bug #47958.

Also, does the system respond to ctrl+C (or the MacOS equivalent)?  If not, I think this should be in Item Group "crash", because hanging is essentially a crash.

Lachlan Andrew <lachlan>
Fri 10 Jun 2016 10:02:13 PM UTC, comment #3: 

So you are not using gnuplot, you are using the qt toolkit. Anything you are doing with reinstalling gnuplot is unrelated.

The package warnings are not related. You can just uninstall the "plot" package, it's not currently maintained and shouldn't be necessary.

If you can help by providing debug information and show where something needs to be fixed in the way that Octave is using OpenGL on OS X, please do so. If you want to interact with the homebrew packagers, you should take a look at the relevant github project, https://github.com/Homebrew/homebrew-science/

Mike Miller <mtmiller>
Project Administrator
Fri 10 Jun 2016 08:27:37 PM UTC, comment #2: 

confirming that graphics_toolkit returns "qt".
I reinstalled gnuplot with qt option set and still observed the hang.
Octave has been throwing the following warnings on startup:

warning: function /Users/davidobrien/octave/plot-1.1.0/zoom.m shadows a core library function
warning: called from
    load_packages_and_dependencies at line 47 column 5
    load_packages at line 60 column 3
    pkg at line 422 column 7
    /usr/local/Cellar/octave/4.0.2_4/share/octave/4.0.2/m/startup/octaverc at line 20 column 1

Hope that helps and sorry I forgot to include these warnings in my original submission.  I will take a look at running Octave in gbd and providing a backtrace - may take a bit longer to do this.

I think the bug is probably with the install or package/packager.  Please let me know if that is out of scope for this defect tracking system.

Regards,
David

David O'Brien <dobrien16>
Fri 10 Jun 2016 07:02:13 PM UTC, comment #1: 

Thanks for your bug report. If you want to help debug and identify problems in the default Octave plotting interface, the first step might be to run Octave in gdb and provide us with a backtrace of what it's doing when you see it hanging and not responding. Also please verify that graphics_toolkit returns "qt".

However, if all you're looking for is help on getting plotting to work in Octave with whatever means necessary, then you should probably ask on the help mailing list, the bug tracker is not a support channel.

Mike Miller <mtmiller>
Project Administrator
Fri 10 Jun 2016 06:41:35 PM UTC, original submission:  

I installed Octave v4.0.2 on my Macbook Air (2012) with OS X El Capitan version 10.11.5 using Homebrew. 

I believe I followed the install procedures correctly and brew reported a successful install.   I have not gotten plotting to work correctly.   Issuing the plot command in Octave resulting in a hang.   I tried uninstalling gnuplot and reinstalling with the x11 build option.  (Please note that I have XQuartz 2.7.9 installed on my machine.  Also installed gnuplot v5.0. ) Running with the x11 version of gnuplot also generated a hang.  Note leaving system to go for lunch and coming back an hour later it was still hung, so I don't think the problem is just a long initialization.

It appears that Octave supports many different plotting options.  Is there a default or recommended plotting option? 

Brew did give one notification that concerned me:
"Octave has been compiled with Apple's BLAS routines, this leads to segfaults in some tests. The option "--with-openblas" is a more conservative choice."
How do I use this option?   Is it recommended and could it be the source of my plotting problems?

Thanks in advance for your help.
Best regards,
David

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #37450:  Octave plotting.docx added by None (83KiB - application/vnd.openxmlformats-officedocument.wordprocessingml.document)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by lachlan (Posted a comment)
  • -email is unavailable- added by dobrien16 (Posted a comment)
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 6 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-06-17 mtmiller StatusNeed Info => Invalid
        Open/ClosedOpen => Closed
    2016-06-10 mtmiller CategoryPlotting => Plotting with OpenGL
    2016-06-10 mtmiller StatusNone => Need Info
    2016-06-10 mtmiller Item GroupSegfault, Bus Error, etc. => Incorrect Result
    2016-06-10 None Attached File- => Added Octave plotting.docx, #37450

    Back to the top


    Powered by Savane 3.5