bugGNU Octave - Bugs: bug #47046, function handle str2func failed

 
 

bug #47046: function handle str2func failed

Submitter:  None
Submitted:  Tue 02 Feb 2016 06:56:25 PM UTC
 
Category:  Octave Function Severity:  3 - Normal
Priority:  5 - Normal Item Group:  WTF, Matlab?!?
Status:  Duplicate Assigned to:  None
Originator Name:  Muzammil Originator Email:  -email is unavailable-
Open/Closed:  * Closed Release:  * 4.0.0
Operating System:  * Microsoft Windows Fixed Release:  None
Planned Release:  None
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Tue 02 Feb 2016 09:31:58 PM UTC, comment #2: 

I think the post the OP is referring to is bug #45682, which has been fixed on the default branch. Closing as a duplicate of that bug.

Mike Miller <mtmiller>
Project Administrator
Tue 02 Feb 2016 07:14:08 PM UTC, comment #1: 

I think that you might be using it wrong.
Here is an example:

function q=pig(x)
q=3*x^5 -100;
endfunction

str1="pig"

fh = str2func(str1)

ie;  str has to be the name of a function , not the function.

HTH

Doug Stewart <dastew>
Tue 02 Feb 2016 06:56:25 PM UTC, original submission:  

fh = str2func(str) brought about the results:
error: @7*x-13: no function and no method found
this bug is old since I have seen an august 2015 post about it. If there is any workaround, kindly let people know about it.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by dastew (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-02-02 mtmiller StatusNone Duplicate
        Open/ClosedOpen Closed
        Dependencies- Depends on bugs #45682

    Back to the top


    Powered by Savane 3.9