bugGNU Octave - Bugs: bug #46458, tab completion does not work for...

 
 

bug #46458: tab completion does not work for the elements of a struct when that struct is a cell of a cell array

Submitted by:  - <_101782>
Submitted on:  Mon 16 Nov 2015 05:05:20 PM UTC
 
Category:  Interpreter Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Feature Request
Status:  Fixed Assigned to:  lachlan
Originator Name:  Martijn Open/Closed:  * Closed
Release:  * dev Operating System:  * Any
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

( Jump to the original submission )

Sat 23 Jul 2016 10:14:02 PM UTC, comment #7: 

I pushed the changeset here:

http://hg.savannah.gnu.org/hgweb/octave/rev/0a4c5a90f286

Lachlan: Please write "* input.h, input.cc (...):"  instead of "* input.{h,cc} (...):".  With the abbreviated version, if someone searches for input.h they would miss this entry.

Oops, I pushed before I noticed that the bug number was missing from the commit message.

John W. Eaton <jwe>
Project Administrator
Fri 01 Jul 2016 10:24:17 AM UTC, comment #6: 

The previous patch missed the "username" metadata.

(file #37645)

Lachlan Andrew <lachlan>
Mon 27 Jun 2016 07:32:54 AM UTC, comment #5: 

thanks for fixing this issue!

- <_101782>
Sun 26 Jun 2016 02:45:13 PM UTC, comment #4: 

Yes I tested the original example and indeed the patch makes it work.

Pantxo Diribarne <pantxo>
Project Member
Sun 26 Jun 2016 10:29:41 AM UTC, comment #3: 

This patch fixes this issue for me.  Could either of you confirm that?

(file #37580)

Lachlan Andrew <lachlan>
Mon 16 Nov 2015 08:44:10 PM UTC, comment #2: 

Hi,

I can confirm this bug. I would also be happy if tab completion worked on struct elements of a cell array, but anyway octave should not print those internals.

Pantxo Diribarne <pantxo>
Project Member
Mon 16 Nov 2015 05:08:21 PM UTC, comment #1: 

sorry I meant "fields of a struct" instead of "elements of a struct"

- <_101782>
Mon 16 Nov 2015 05:05:20 PM UTC, original submission:  

tab completion does not work for the elements of a struct when that struct is a cell of a cell array. After running the code snippet below, when I type "t1." and then tab I get "t1.t2  t1.t3" as expected. However when I type "t4{ 1 }." and then tab I get "./        ../       .nargin.".

t1.t2 = 1
t1.t3 = 2
t4{ 1 } = t1

- <_101782>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Updated the item)
  • -email is unavailable- added by jwe (Posted a comment)
  • -email is unavailable- added by lachlan (Updated the item)
  • -email is unavailable- added by pantxo (Posted a comment)
  • -email is unavailable- added by _101782 (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 12 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-11-23 rik5 StatusReady For Test => Fixed
        Open/ClosedOpen => Closed
    2016-07-23 jwe StatusPatch Submitted => Ready For Test
    2016-07-01 lachlan Attached File- => Added bug_46458_complete_struct_array.cset, #37645
    2016-06-26 lachlan Attached File- => Added bug_46458_complete_struct_array.cset, #37580
        Item GroupNone => Feature Request
        StatusConfirmed => Patch Submitted
        Assigned toNone => lachlan
        Originator Name => Martijn
        Release4.0.0 => dev
        Operating SystemMicrosoft Windows => Any
    2015-11-16 pantxo StatusNone => Confirmed

    Back to the top


    Powered by Savane 3.9