bugGNU Octave - Bugs: bug #46285, segfault when ploting visible...

 
 

bug #46285: segfault when ploting visible figure

Submitted by:  Francisco Albani <falbani>
Submitted on:  Sun 25 Oct 2015 12:07:51 AM UTC  
 
Category:  Plotting with OpenGL Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Segfault, Bus Error, etc.
Status:  Duplicate Assigned to:  None
Originator Name:  falbani Open/Closed:  Closed
Release:  4.0.0 Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 07 Jan 2017 04:45:12 AM UTC, comment #3: 

I did't have epstools installed (Kubuntu 16.04), and I am able to duplicate the crash, working through the tutorial.
GNU Octave, version 4.0.0 first without epstool, then with it installed. Both segfault.

function xdot = f(x, t)
r = 0.25;
k = 1.4;
a = 1.5;
b = 0.16;
c = 0.9;
d = 0.8;
xdot(1) = r*x(1)*(1 - x(1)/k) - a*x(1)*x(2)/(1+b*x(1));
xdot(2) = c*a*x(1)*x(2)/(1+b*x(1))-d*x(2);
endfunction

x0 = [1; 2];
t = linspace(0,50,200)';
x = lsode("f", x0, t);
plot(t,x)

This works fine. But when I:

print -dpdf foo.pdf

I get an warning that epstool is not installed, and the gui for Octave segfaults.

octave exited with signal 11

strace without epstool (woepstoolsSF)

Installed epstool didn't help (epstoolsSF attached).

(file #39394, file #39395)

Anonymous
Mon 21 Mar 2016 10:26:06 PM UTC, comment #2: 

Without any further details from the reporter, let's consider this a duplicate of bug #44823.

Mike Miller <mtmiller>
Project Administrator
Fri 29 Jan 2016 11:22:14 PM UTC, comment #1: 

Thanks, Francisco.  Is this a duplicate of bug #44823?

Lachlan Andrew <lachlan>
Sun 25 Oct 2015 12:07:51 AM UTC, original submission:  

Example:

$ octave-cli -q
octave:1> version
ans = 4.0.0
octave:2> graphics_toolkit
ans = fltk
octave:3> plot(1:10,1:10)
octave:4> print('asd.pdf')
warning: print.m: epstool binary is not available.
Some output formats are not available.
warning: called from
    __print_parse_opts__ at line 382 column 9
    print at line 288 column 8
warning: print.m: fig2dev binary is not available.
Some output formats are not available.
warning: print.m: pstoedit binary is not available.
Some output formats are not available.
panic: Segmentation fault -- stopping myself...
attempting to save variables to 'octave-workspace'...
save to 'octave-workspace' complete
ViolaciĆ³n de segmento (`core' generado)
$

Workaround:

$ octave-cli -q
octave:1> figure(1, 'visible', 'off')
octave:2> plot(1:10,1:10)
octave:3> print('asd.pdf')
warning: print.m: epstool binary is not available.
Some output formats are not available.
warning: called from
    __print_parse_opts__ at line 382 column 9
    print at line 288 column 8
warning: print.m: fig2dev binary is not available.
Some output formats are not available.
warning: print.m: pstoedit binary is not available.
Some output formats are not available.
octave:4>

Some context:

$ lspci | grep VGA
00:02.0 VGA compatible controller: Intel Corporation Broadwell-U Integrated Graphics (rev 09)
$ uname -a
Linux coal 4.2.3-1-ARCH #1 SMP PREEMPT Sat Oct 3 18:52:50 CEST 2015 x86_64 GNU/Linux

I'm on a up-to-date Arch Linux, with this installed packages:

$ pacman -Qsq octave
octave
octave-communications
octave-control
octave-data-smoothing
octave-general
octave-io
octave-linear-algebra
octave-miscellaneous
octave-optim
octave-signal
octave-statistics
octave-struct
vim-octave

Francisco Albani <falbani>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #39394:  woepstoolsSF added by None (15KiB - application/octet-stream)
file #39395:  epstoolsSF added by None (17KiB - application/octet-stream)

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Updated the item)
  • -email is unavailable- added by lachlan (Posted a comment)
  • -email is unavailable- added by falbani (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 7 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2017-01-07 None Attached File- => Added woepstoolsSF, #39394
        Attached File- => Added epstoolsSF, #39395
    2016-03-21 mtmiller StatusNeed Info => Duplicate
        Open/ClosedOpen => Closed
        Dependencies- => Depends on bugs #44823
    2016-02-21 mtmiller CategoryPlotting => Plotting with OpenGL
        StatusNone => Need Info

    Back to the top


    Powered by Savane 3.5