bugGNU Octave - Bugs: bug #46192, JIT compiler fails in jit.tst and...

 
 

bug #46192: JIT compiler fails in jit.tst and aborts Octave

Submitter:  Rik <rik5>
Submitted:  Mon 12 Oct 2015 11:22:38 PM UTC
 
Category:  Interpreter Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Segfault, Bus Error, etc.
Status:  Wont Fix Assigned to:  None
Originator Name:  Open/Closed:  * Closed
Release:  * dev Operating System:  * GNU/Linux
Fixed Release:  None Planned Release:  None
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Thu 23 Dec 2021 12:43:37 PM UTC, comment #4: 

Closing report.

Markus M├╝tzel <mmuetzel>
Project Member
Thu 23 Dec 2021 02:32:28 AM UTC, comment #3: 

Close this bug since JIT removed?

Anonymous
Tue 01 Dec 2015 05:46:18 PM UTC, comment #2: 

Since JIT is not actively supported, I am marking this bug as postponed.  If JIT is taken back up again at some point it is likely to have a very different implementation underneath.

Rik <rik5>
Project Administrator
Tue 13 Oct 2015 02:33:52 PM UTC, comment #1: 

Simple test case is

a=[1 2]; do a(3); until(1)

root cause are modifications for out_of_range errors in cset dd6345fd8a97

Anonymous
Mon 12 Oct 2015 11:22:38 PM UTC, original submission:  

I haven't tried to compile in the JIT compiler in quite a while.  After fixing the build process in cset d35201e5ce5d Octave builds.  Octave works fine for ordinary operations, but running the tests in jit.tst produce the following error

run-octave -f --no-gui-libs
cd test
test jit.tst
terminate called after throwing an instance of 'out_of_range'
Abort

From looking in to jit.tst, the problem seems to be with %!tests which use try/catch blocks.  If I comment out those tests which use that construct then the rest of the file passes.;

Rik <rik5>
Project Administrator

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mmuetzel (Posted a comment)
  • -email is unavailable- added by rik5 (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2021-12-23 mmuetzel StatusPostponed Wont Fix
        Open/ClosedOpen Closed
    2015-12-01 rik5 StatusNone Postponed

    Back to the top


    Powered by Savane 3.9