bugGNU Octave - Bugs: bug #45666, title and xlabel text merging in...

 
 

bug #45666: title and xlabel text merging in subplot

Submitted by:  alex <alex1243>
Submitted on:  Fri 31 Jul 2015 05:45:10 AM UTC  
 
Category:  Plotting with gnuplot Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Other
Status:  Duplicate Assigned to:  None
Originator Name:  text merging during subplot Open/Closed:  Closed
Release:  3.8.1 Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 01 Aug 2015 06:23:05 AM UTC, comment #4: 

ok sorry for the duplicate,
And thank you very much from all for the help

:)

alex <alex1243>
Fri 31 Jul 2015 05:09:36 PM UTC, comment #3: 

I try multiplot in gnuplot and default title/label placement for the terminals appears reasonably good.  So Octave must be altering something in order to make the graph area bigger, perhaps?  If that is done, then readjustment must be made for the labels.

As far as title/xlabel/ylabel placement, it's possible to specify an "offset".  That offset can be in relation to several different coordinate systems.  From the documentation:

"
It may be preceded by `first`, `second`, `graph`, `screen`,
 or `character` to select the coordinate system.  See `coordinates` for
 details.
"

Probably "graph" is the most logical one to use in this case, e.g.,

set title graph 0.5,1.05
set xlabel graph 0.5,-0.05

Something like that.  Is there some representation in the properties that is similar?  There appears to be:

get(get(gca,'title'))
...
    position =

       1.00000   1.12360   0.50000

Those positions look very similar to graph-relative coordinates.

It doesn't have to be exact, but if those 'title' position values could be mapped to

set title graph 0.50000,1.12360

it effectively puts control in the hands of the user to tweak things.  No matter what tool I've used for generating journal paper plots there is always some tweaking involved.  I'm never expecting exact label extent knowledge, but often times that isn't of critical importance, just that it is reasonably good and can be controlled.

Dan Sebald <sebald>
Fri 31 Jul 2015 01:41:54 PM UTC, comment #2: 

Text is often tight in subplots. It helps to choose
a smaller font and/or use text() to position the text
you want.

Michael Godfrey <godfrey>
Project Member
Fri 31 Jul 2015 11:46:18 AM UTC, comment #1: 

Thanks for your bug report. Several similar bugs have been reported already against the gnuplot toolkit, see for example bug #31610, bug #34148, and bug #41154.

The consensus opinion among Octave developers seems to be that this problem lies with limited control we have in the interaction with gnuplot, and the solution is to use one of the OpenGL-based plotting toolkits ("qt" or "fltk") instead where Octave truly has control over the layout of figures.

Closing as a duplicate of bug #31610.

Mike Miller <mtmiller>
Project Administrator
Fri 31 Jul 2015 05:45:10 AM UTC, original submission:  

Hello,

If i try to create several plots with subplots, and if i give some titles and xlabel a bit too long.
If i save the plot in pdf with print, the titles and the xlabels merge.

In the exemple I use 6 subplots in total

Thank you and sorry if it was already known

alex <alex1243>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #34560:  temp2.m added by alex1243 (772B - text/x-objcsrc - exemple of the code, it create a eps file with merged text)

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by sebald (Posted a comment)
  • -email is unavailable- added by godfrey (Posted a comment)
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by alex1243 (Submitted the item)
  • -email is unavailable- added by alex1243
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-07-31 mtmiller StatusNone => Duplicate
        Open/ClosedOpen => Closed
        Dependencies- => Depends on bugs #31610
    2015-07-31 alex1243 Attached File- => Added temp2.m, #34560
        Carbon-Copy- => Added alexandre.brieussel@anu.edu.au

    Back to the top


    Powered by Savane 3.5