bugGNU Octave - Bugs: bug #45543, make attempts to build libgui even...

 
 

bug #45543: make attempts to build libgui even with '--disable-gui'

Submitter:  Guillaume <gyom>
Submitted:  Mon 13 Jul 2015 03:43:03 PM UTC
   
 
Category:  Configuration and Build System Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Build Failure
Status:  Fixed Assigned to:  None
Originator Name:  Guillaume Open/Closed:  * Closed
Release:  * dev Operating System:  * Any
Fixed Release:  None Planned Release:  None
* Mandatory Fields

Add a New Comment Rich Markup
   

Jump to the original submission

Fri 17 Jul 2015 10:42:47 AM UTC, comment #12: 

It works for me now as well so this bug can be closed. Thanks!

Guillaume <gyom>
Fri 17 Jul 2015 05:10:07 AM UTC, comment #11: 

I get this error too, doesn't matter whether --disable-gui is given or not.

Fixed in this changeset:

http://hg.savannah.gnu.org/hgweb/octave/rev/0932426e3866

Any remaining issues? I think this bug can be closed.

Mike Miller <mtmiller>
Group Member
Thu 16 Jul 2015 03:08:37 PM UTC, comment #10: 

I don't see anything obvious but I might not be looking at the right place:


       Finished prerequisites of target file 'run-octave'.
       Prerequisite '../run-octave.in' is older than target 'run-octave'.
       Prerequisite 'Makefile' is newer than target 'run-octave'.
      Must remake target 'run-octave'.
Putting child 0x4692db0 (run-octave) PID 963 on the chain.
Live child 0x4692db0 (run-octave) PID 963
  GEN      run-octave
run-octave is unchanged
Reaping winning child 0x4692db0 PID 963
Removing child 0x4692db0 PID 963 from chain.
      Successfully remade target file 'run-octave'.
     Finished prerequisites of target file 'doc/interpreter/voronoi.txt'.
    Must remake target 'doc/interpreter/voronoi.txt'.
Putting child 0x46b9b20 (doc/interpreter/voronoi.txt) PID 969 on the chain.
Live child 0x46b9b20 (doc/interpreter/voronoi.txt) PID 969
  GEN      doc/interpreter/voronoi.txt
/octave/.build/libtool: line 10062: /octave/.build/src/octave: No such file or directory
Reaping losing child 0x46b9b20 PID 969
Makefile:27834: recipe for target 'doc/interpreter/voronoi.txt' failed


I thought the problem was coming from the fact that src/ contains octave-cli, octave-cli-4.1.0+, octave-gui and octave-gui-4.1.0+ but not octave.

Guillaume <gyom>
Thu 16 Jul 2015 02:18:26 PM UTC, comment #9: 

Could you please run


make -d ... other options you used before ... >& make-log


and then look at the end of the log file to see what file(s) were out of date and triggered that rule?

John W. Eaton <jwe>
Group administrator
Thu 16 Jul 2015 02:13:59 PM UTC, comment #8: 

I don't understand why you see this failure.  The image files depend on the interpreter targets, which includes src/octave.

John W. Eaton <jwe>
Group administrator
Thu 16 Jul 2015 11:34:48 AM UTC, comment #7: 

Thanks John, your change indeed fixes the problem.

I now get the following error later on:


  CXXLD  src/octave-cli
  GEN    src/octave-cli-4.1.0+
  GEN    scripts/plot/util/gnuplot_binary.m
scripts/plot/util/gnuplot_binary.m is unchanged
  GEN    scripts/.DOCSTRINGS
  GEN    run-octave
run-octave is unchanged
  GEN    doc/interpreter/voronoi.txt
/opt/octave/.build/libtool: line 8880: /opt/octave/.build/src/octave: No such file or directory
/opt/octave/.build/libtool: line 8880: exec: /opt/octave/.build/src/octave: cannot execute: No such file or directory
make[2]: *** [doc/interpreter/voronoi.txt] Error 126



Guillaume <gyom>
Thu 16 Jul 2015 09:52:41 AM UTC, comment #6: 

re-enabling --enable-docs the build completed successfully, so this issue seems to be fixed.

Carlo de Falco <cdf>
Group Member
Thu 16 Jul 2015 09:10:07 AM UTC, comment #5: 

While checking whether this problem was gone I encountered the
issue described in the new bug report #45560

Carlo de Falco <cdf>
Group Member
Wed 15 Jul 2015 07:27:51 PM UTC, comment #4: 

I think the following change should fix this problem:

http://hg.savannah.gnu.org/hgweb/octave/rev/c3dab5d8e6ab

John W. Eaton <jwe>
Group administrator
Wed 15 Jul 2015 06:45:50 PM UTC, comment #3: 

I'll take a look at this next.

John W. Eaton <jwe>
Group administrator
Wed 15 Jul 2015 06:11:16 PM UTC, comment #2: 

Thanks for the feedback - I'll wait and report another build issue in a minute.

Guillaume <gyom>
Mon 13 Jul 2015 06:41:07 PM UTC, comment #1: 

Confirmed, the --disable-gui is mostly not working now due to the recent build system reorganization. It will be fixed soon-ish, please be patient and feel free to keep reporting odd build problems.

Mike Miller <mtmiller>
Group Member
Mon 13 Jul 2015 03:43:03 PM UTC, original submission:  

When doing a fresh compilation of the tip (20338:a7770c66cb3d), I get this error:


  GEN    libgui/src/ui-settings-dialog.h
/bin/sh: -o: command not found
make: *** [libgui/src/ui-settings-dialog.h] Error 127


(I use ./configure --without-opengl --without-framework-opengl --disable-gui)

Guillaume <gyom>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by cdf (Posted a comment)
  • -email is unavailable- added by jwe (Posted a comment)
  • -email is unavailable- added by cdf (sunscribing to this bug as it makes impossible to build on OSX where gui does not work)
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by gyom (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only group members can vote.

     

    Follow 7 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-07-17 mtmiller StatusConfirmed Fixed
        Open/ClosedOpen Closed
    2015-07-14 cdf Carbon-Copy- Added -email is unavailable-
    2015-07-13 mtmiller CategoryNone Configuration and Build System
        StatusNone Confirmed
        Operating SystemGNU/Linux Any
        SummaryCompilation error with libgui/src/ui-settings-dialog.h make attempts to build libgui even with '--disable-gui'

    Back to the top

    Powered by Savane 3.13-4b48.
    Corresponding source code