bugGNU Octave - Bugs: bug #44963, Wrong plotting with fltk,...

 
 

bug #44963: Wrong plotting with fltk, according to values in the data

Submitter:  Rafael Laboissière <rlaboiss>
Submitted:  Thu 30 Apr 2015 12:08:22 AM UTC
 
Category:  Plotting Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  * Closed
Release:  * 4.0.0 Operating System:  * GNU/Linux
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Tue 02 Jun 2015 04:52:56 PM UTC, comment #3: 

Retagging release from 4.0.0-rc4 to 4.0.0.

John W. Eaton <jwe>
Project Administrator
Thu 30 Apr 2015 12:21:22 AM UTC, comment #2: 

This is a result of the fact that OpenGL uses variables of type single, ~8 digits of precision, while gnuplot uses doubles.

This is a duplicate of bug #32980 and bug #33748.

In particular, see bug #33748 for workarounds.  The current workaround to increase the differences in the data above the noise floor of the single variables.  The easiest way it to subtract the mean from the data and then set the xlabels to your desired values by hand.

Closing report as a duplicate.

Rik <rik5>
Project Administrator
Thu 30 Apr 2015 12:15:12 AM UTC, comment #1: 

Hey Rafael, looks like we just passed each other on upstreaming the Debian bug report :) Closing this as a duplicate of long-standing bug #32980.

Mike Miller <mtmiller>
Project Administrator
Thu 30 Apr 2015 12:08:22 AM UTC, original submission:  

This issue has been reported as a bug against the Debian package octave (http://bugs.debian.org/783624).

Using the data in the file attached to this bug report (data.mat), the plot with gnuplot produces a correct result (see attached file gnuplot.pdf):

load data.mat
close all
graphics_toolkit ("gnuplot")
plot (data (:, 1), data (:, 2))

However, the result is clearly wrong with fltk (see atached file fltk.pdf):

load data.mat
close all
graphics_toolkit ("fltk")
plot (data (:, 1), data (:, 2))

Also, the labels on the vertical axis appear at the wrong places.

This is due to a bad conditioning of the data and the problem disappears when the data on the horizontal axis is translated:

load data.mat
close all
graphics_toolkit ("fltk")
plot (data (:, 1) - data (1, 1), data (:, 2))

This seems to be a bug in the fltk graphics backend.

Rafael Laboissière <rlaboiss>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #33840:  data.mat added by rlaboiss (1KiB - application/octet-stream)
file #33841:  fltk.pdf added by rlaboiss (5KiB - application/pdf)
file #33842:  gnuplot.pdf added by rlaboiss (6KiB - application/pdf)

 

Carbon-Copy List
  • -email is unavailable- added by jwe (Posted a comment)
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by rlaboiss (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 12 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-06-02 jwe Release4.0.0-rc4 4.0.0
    2015-04-30 rik5 Dependencies- Depends on bugs #33748
    2015-04-30 rik5 CategoryPlotting with OpenGL Plotting
        Operating SystemAny GNU/Linux
    2015-04-30 mtmiller Open/ClosedOpen Closed
        Operating SystemGNU/Linux Any
        Dependencies- Depends on bugs #32980
    2015-04-30 mtmiller CategoryPlotting Plotting with OpenGL
        StatusNone Duplicate
    2015-04-30 rlaboiss Attached File- Added data.mat, #33840
        Attached File- Added fltk.pdf, #33841
        Attached File- Added gnuplot.pdf, #33842

    Back to the top


    Powered by Savane 3.9