bugGNU Octave - Bugs: bug #44692, [GUI] Undocked editor pane has no...

 
 

bug #44692: [GUI] Undocked editor pane has no Minimize button

Submitter:  Philip Nienhuis <philipnienhuis>
Submitted:  Wed 01 Apr 2015 07:52:12 PM UTC
   
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Feature Request
Status:  Wont Fix Assigned to:  None
Originator Name:  Philip Nienhuis Open/Closed:  * Closed
Release:  * dev Operating System:  * GNU/Linux
Fixed Release:  None Planned Release:  None
* Mandatory Fields

Add a New Comment Rich Markup
   

Jump to the original submission

Sun 22 Apr 2018 08:14:45 PM UTC, comment #11: 

I think this bug, like bug #53276, is caused by KDE's Oxygen theme deficiencies. Selecting other themes / widget styles make this bug go away.

So, closing report, as "won't fix" as this is an upstream bug.

Philip Nienhuis <philipnienhuis>
Group Member
Sun 03 Sep 2017 03:18:31 PM UTC, comment #10: 

The window is available via "Alt+Tab".  The KDE window manager clearly knows about it, but is simply refusing to decorate it.  Probably, because the type is "Qt Dock Widget".

In another interesting turn of events, the name of the window as listed in the Alt+Tab menu is "&Variable Editor".  There is another bug report about that, but clearly this is related.  Top-Level Menu Titles shouldn't include shortcut codes is my guess.

Rik <rik5>
Group administrator
Sat 02 Sep 2017 01:54:40 PM UTC, comment #9: 

I think you are right, KDE prevents a "Qt Dock Widget" from being decorated. Is an undocked widget (at least) separately available via "Alt-Tab"?


Torsten Lilge <ttl>
Group Member
Sat 02 Sep 2017 12:39:28 PM UTC, comment #8: 

Alas, the patch didn't work.  I added a debug statement just to make sure I was executing the code, and it is being run.


  std::cerr << "executing setWindowFlags" << std::endl;
  // non windows: Just set the appropriate window flag
  setWindowFlags (Qt::Window | Qt::WindowTitleHint);


I went even further and added Qt::WindowMinimizeButtonHint, but it didn't help.


  setWindowFlags (Qt::Window | Qt::WindowTitleHint | Qt::WindowMinimizeButtonHint);


I wonder if it is the KDE Window Manager that is refusing to decorate the undocked window?  I found this webpage: https://techbase.kde.org/Projects/KWin/Window_Decoration_Policy.


In general all windows managed (windows without override-redirect) by the Window Manager (KWin) are re-parented into a Server-Side Decoration unless:

    The window has _NET_WM_WINDOW_TYPE _NET_WM_WINDOW_TYPE_DESKTOP
    The window has _NET_WM_WINDOW_TYPE _NET_WM_WINDOW_TYPE_DOCK
    The window has _NET_WM_WINDOW_TYPE _NET_WM_WINDOW_TYPE_SPLASH
    The window belongs to the Desktop Shell
    The window has _NET_WM_STATE _NET_WM_STATE_ABOVE and has set an own XShape
    The window is a "Qt Dock Widget"


Maybe the window type remains _NET_WM_WINDOW_TYPE_DOCK even after it is detached?

Rik <rik5>
Group administrator
Sat 02 Sep 2017 10:50:06 AM UTC, comment #7: 

In contrast to windows or other desktop environments, Philip's screenshot doesn't show any window decorations at all, especially no title bar. Could you please try the following simple patch on a KDE system?

(file #41716)

Torsten Lilge <ttl>
Group Member
Sat 02 Sep 2017 07:43:52 AM UTC, comment #6: 

Besides KDE, are there any other desktop environments known, which are affected?

Torsten Lilge <ttl>
Group Member
Fri 01 Sep 2017 07:40:03 PM UTC, comment #5: 

Still the same on Linux.  Interestingly, it seems to work on Windows.

When the undock operation is executed, isn't there a function call or switch to say that this is a top-level widget that should have window decorations?

Rik <rik5>
Group administrator
Wed 22 Apr 2015 04:56:41 AM UTC, comment #4: 

Confirmed.  I notice this as well on Kubuntu 12.04 with an undocked editor.

Rik <rik5>
Group administrator
Thu 02 Apr 2015 12:13:01 PM UTC, comment #3: 

I mis-spoke, - it is firing for the topLevelChanged

John Donoghue <lostbard>
Group Member
Wed 01 Apr 2015 09:05:21 PM UTC, comment #2: 

A quick look online, and it looks like normally the QToolWdget doesn't have a minimize button but can be faked up by setting the window flags to Qt::Window and Qt::Widget depending on whether it is floating or not.

That is being done in octave-dock-widget class, when the topLevelChanged is emitted, but it doesn't appear to be getting it.

John Donoghue <lostbard>
Group Member
Wed 01 Apr 2015 08:37:28 PM UTC, comment #1: 

It is on all undocked panes in fedora

John Donoghue <lostbard>
Group Member
Wed 01 Apr 2015 07:52:12 PM UTC, original submission:  

See attached pic of Octave on my Mageia-4 KDE desktop with undocked editor pane.

Unlike on e.g., Windows, I see no minimize button, just the Close and Dock buttons.
I haven't checked but AFAIR this goes for all undocked panes.

Philip Nienhuis <philipnienhuis>
Group Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #41716:  bug44692_v01.patch added by ttl (797B - text/x-patch)
file #33507:  Oct_editor1.png added by philipnienhuis (497KiB - image/png)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by ttl (Posted a comment)
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by lostbard (Posted a comment)
  • -email is unavailable- added by philipnienhuis (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only group members can vote.

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-04-22 philipnienhuis StatusConfirmed Wont Fix
        Open/ClosedOpen Closed
    2017-09-02 ttl Attached File- Added bug44692_v01.patch, #41716
    2015-04-22 rik5 StatusNone Confirmed
    2015-04-01 philipnienhuis Attached File- Added Oct_editor1.png, #33507

    Back to the top

    Powered by Savane 3.13-ee12.
    Corresponding source code