bugGNU Octave - Bugs: bug #44691, Mouse interaction with image...

 
 

bug #44691: Mouse interaction with image objects don't work in fltk toolkit

Submitter:  Guillaume <gyom>
Submitted:  Wed 01 Apr 2015 05:45:37 PM UTC
   
 
Category:  Plotting with OpenGL Severity:  3 - Normal
Priority:  3 - Low Item Group:  Incorrect Result
Status:  Wont Fix Assigned to:  None
Originator Name:  Guillaume Open/Closed:  * Closed
Release:  * dev Operating System:  * Any
Fixed Release:  None Planned Release:  None
* Mandatory Fields

Add a New Comment Rich Markup
   

Jump to the original submission

Sun 03 Mar 2019 05:45:11 PM UTC, comment #8: 

Mouse interactions in FLTK are probably never going to be fixed so I'll close this FLTK specific bug as "Won't Fix".

Pantxo Diribarne <pantxo>
Group Member
Tue 14 Aug 2018 10:25:03 PM UTC, comment #7: 

Changing priority to low as the FLTK toolkit is no longer being actively developed in Octave.

Rik <rik5>
Group administrator
Sat 25 Apr 2015 01:12:30 PM UTC, comment #6: 

Thank you Pantxo!

Guillaume <gyom>
Sat 25 Apr 2015 12:45:46 PM UTC, comment #5: 

Thanks Guillaume for testing. I pushed the patch at http://hg.savannah.gnu.org/hgweb/octave/rev/e05fe4260252

The problem is unchanged for fltk so I am leaving the bug report open and retitling to better describe the remaining issues.

Pantxo Diribarne <pantxo>
Group Member
Sat 18 Apr 2015 11:46:32 AM UTC, comment #4: 

Given that it fixes the problem and works great, is there any chance it could make it into 4.0.0 or is it too late for this?

Guillaume <gyom>
Fri 17 Apr 2015 10:35:09 AM UTC, comment #3: 

Thank you very much Pantxo, I confirm it works for me too!


Guillaume <gyom>
Thu 16 Apr 2015 09:03:30 PM UTC, comment #2: 

I attached a patch that fixes both issues for me (in qt toolkit only).

(file #33695)

Pantxo Diribarne <pantxo>
Group Member
Wed 01 Apr 2015 06:12:16 PM UTC, comment #1: 

Maybe related, the "buttondownfcn" callback does not work on an image:


F = figure;
H = imagesc(rand(64));
set(H,'ButtonDownFcn','disp(''click'')');


It does work on a axis as discussed in bug #39580.

Guillaume <gyom>
Wed 01 Apr 2015 05:45:37 PM UTC, original submission:  

A context menu does not appear when attached to an image. It does work when attached to a figure or axis.


F = figure;
H = imagesc(rand(32));
U = uicontextmenu(F);
uimenu(U,'Label','Entry 1');
uimenu(U,'Label','Entry 2');
set(H,'UIContextMenu',U);


Guillaume <gyom>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #33695:  fix_image.patch added by pantxo (2KiB - text/x-diff)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by pantxo (Updated the item)
  • -email is unavailable- added by gyom (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only group members can vote.

     

    Follow 11 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-03-03 pantxo StatusConfirmed Wont Fix
        Open/ClosedOpen Closed
    2018-08-14 rik5 Priority5 - Normal 3 - Low
        StatusNone Confirmed
    2015-04-25 pantxo StatusPatch Submitted None
        Operating SystemGNU/Linux Any
        SummaryContext menu attached to an image Mouse interaction with image objects don't work in fltk toolkit
    2015-04-16 pantxo Attached File- Added fix_image.patch, #33695
        CategoryPlotting Plotting with OpenGL
        Item GroupNone Incorrect Result
        StatusNone Patch Submitted

    Back to the top

    Powered by Savane 3.13-4b48.
    Corresponding source code