bugGNU Octave - Bugs: bug #44359, Save and restore user FFLAGS, add...

 
 

bug #44359: Save and restore user FFLAGS, add additional options to AM_FFLAGS

Submitted by:  Mike Miller <mtmiller>
Submitted on:  Tue 24 Feb 2015 03:09:49 AM UTC  
 
Category:  Configuration and Build System Severity:  2 - Minor
Priority:  5 - Normal Item Group:  Feature Request
Status:  Wont Fix Assigned to:  None
Originator Name:  Open/Closed:  Closed
Release:  dev Operating System:  Any

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Thu 12 Jul 2018 08:16:06 PM UTC, comment #6:

I am closing this because I don't have the time to test combinations at the moment. If it comes up again I will take a look at it then.

Mike Miller <mtmiller>
Project Administrator
Thu 12 Jul 2018 12:12:11 AM UTC, comment #5:

@Mike: According to the last comment (#4) this bug is open pending resolution of bug #50339 which has been resolved for a while. Can we close this?

Rik <rik5>
Project Administrator
Thu 07 Sep 2017 09:26:56 PM UTC, comment #4:

I think it is, pending resolution of bug #50339. My hope was if the user wants to build with FFLAGS="-g", and configure decides that it needs to add -fdefault-integer-8, then there should be a separate XTRA_FFLAGS variable with -fdefault-integer-8 and FFLAGS should be just -g.

Mike Miller <mtmiller>
Project Administrator
Fri 01 Sep 2017 07:28:07 PM UTC, comment #3:

Is this bug still relevant? configure.ac has been changed quite a bit since Feb. 2015.

Rik <rik5>
Project Administrator
Tue 24 Feb 2015 04:53:07 AM UTC, comment #2:

Sounds good, and this is working for me. Updating the title and marking postponed to work on later.

Mike Miller <mtmiller>
Project Administrator
Tue 24 Feb 2015 04:08:08 AM UTC, comment #1:

For now, I just did this:

http://hg.savannah.gnu.org/hgweb/octave/rev/4006a7377a19

It seems complicated by the fact that we might need to add more than one or two things to FFLAGS to get tests to succeed if we have to link with BLAS libraries and we need -fdefault-integer-8 or -ff2c. It seems easier for now to just not save and restore FFLAGS. Maybe later we can revisit this problem.

John W. Eaton <jwe>
Project Administrator
Tue 24 Feb 2015 03:09:49 AM UTC, original submission:

The changes to save and restore the user compiler flags aren't working quite right with FFLAGS.

One problem is that FFLAGS is saved way too early, before the defaults are set and the compiler detected. If FFLAGS is not given to configure by the user, it will always be empty.

Another problem is that there is no XTRA_FFLAGS. A few flags may have been added to FFLAGS in previous versions of Octave, such as -mieee or -ff2c. I think these will now be discarded at the end of configure. It might not be too hard to introduce an XTRA_FFLAGS variable to handle these for the liboctave directory.

I'll take a look at this if jwe or rik don't beat me too it.

Mike Miller <mtmiller>
Project Administrator

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by jwe (Posted a comment)
  • -email is unavailable- added by mtmiller (Submitted the item)
  • -email is unavailable- added by mtmiller
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 9 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2018-07-12 mtmiller StatusNeed Info => Wont Fix
        Open/ClosedOpen => Closed
    2018-07-12 rik5 StatusPostponed => Need Info
    2017-09-07 mtmiller Dependencies- => Depends on bugs #50339
    2015-02-24 mtmiller Severity4 - Important => 2 - Minor
        Item GroupRegression => Feature Request
        StatusNone => Postponed
        SummaryFFLAGS not set correctly now => Save and restore user FFLAGS, add additional options to AM_FFLAGS
    2015-02-24 mtmiller Carbon-Copy- => Added jwe

    Back to the top


    Powered by Savane 3.3