bugGNU Octave - Bugs: bug #42436, Unable to print TeX labels to .eps...

 
 

bug #42436: Unable to print TeX labels to .eps and .ps formats with fltk

Submitted by:  None
Submitted on:  Tue 27 May 2014 08:45:17 AM UTC  
 
Category:  Plotting with OpenGL Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  Duplicate Assigned to:  None
Originator Name:  CC Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  3.8.1
Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Fri 30 May 2014 04:53:38 AM UTC, comment #2: 

Yes, you are correct. I add a line:

graphics_toolkit ("gnuplot")

, and everything works fine. So this is actually a fltk problem.

Thanks a lot.

CC

Anonymous
Wed 28 May 2014 07:34:39 AM UTC, comment #1: 

You mention gnuplot but are you actually using it? At startup, fltk is the default backend (see what  "graphics_toolkit ()" returns) since 3.8 series.

If you can confirm you are using fltk and not gnuplot, this is a duplicate of bug #42320 (and maybe another one I couldn't find.

Pantxo Diribarne <pantxo>
Project Member
Tue 27 May 2014 08:45:17 AM UTC, original submission:  

Recently I upgraded from Ubuntu 13.10 to 14.04, which brings the Octave from 3.6.4 to 3.8.1 and the gnuplot from 4.6.3 to 4.6.4. After the upgrade, the TeX symbols in plots do not work correctly in the output files.

Example code:


x=linspace(0,1,100);
plot(x,2*x);
title('\Pi');
print('testfig.ps','-dps2','-color');
pause;


The graph shown on the screen displays the Greek character "Pi" correctly, but the output file "testfig.ps" only shows a string "Pi" in Roman characters.

Similar problem also occurs for "-deps" format, and also superscript and subscript do not work.

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mtmiller (Updated the item)
  • -email is unavailable- added by pantxo (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2014-05-30 mtmiller CategoryPlotting with gnuplot => Plotting with OpenGL
        StatusNone => Duplicate
        Open/ClosedOpen => Closed
        SummaryUnable to print TeX labels to .eps and .ps formats with gnuplot => Unable to print TeX labels to .eps and .ps formats with fltk
        Dependencies- => Depends on bugs #42320

    Back to the top


    Powered by Savane 3.5