bugGNU Octave - Bugs: bug #41347, GUI editor code completion popup...

 
 

bug #41347: GUI editor code completion popup blocks keyboard input on RHEL 6

Submitted by:  None
Submitted on:  Sat 25 Jan 2014 02:22:59 PM UTC  
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Other
Status:  Wont Fix Assigned to:  None
Originator Name:  Dirk Krause Originator Email:  -email is unavailable-
Open/Closed:  Closed Release:  3.8.0
Operating System:  GNU/Linux

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

( Jump to the original submission)

Sat 07 Feb 2015 01:53:48 PM UTC, comment #6: 

It looks to me like this was a reported bug in QScintilla and was fixed in version 2.4.1 of the library. It was an interaction between QScintlla and the GNOME desktop environment. There's not much that can be done about this in Octave, other than to say we recommend building with a newer version of QScintilla.

References:
https://bugzilla.redhat.com/show_bug.cgi?id=474462
http://www.riverbankcomputing.com/pipermail/qscintilla/2008-December/000427.html

Mike Miller <mtmiller>
Project Administrator
Sat 07 Feb 2015 06:24:28 AM UTC, comment #5: 

Is this still a problem?  The latest stable release is 3.8.2 and there are going to be release candidates for 4.0 soon.  So much improvement has taken place I'd be surprised if this were still an issue.

Rik <rik5>
Project Administrator
Tue 28 Jan 2014 01:28:03 AM UTC, comment #4: 

Ok, thanks for that info, I can reproduce what you're seeing after building in a CentOS 6 chroot.

Mike Miller <mtmiller>
Project Administrator
Mon 27 Jan 2014 09:23:50 PM UTC, comment #3: 

Hi, Torsten and Mike,
thanks for your responses.
I use Scientific Linux 6x (an RHEL clone), 32-bit. QScintilla is version 2.4 release 1.el6.
As you asked for qscintilla version, I took a look at the website, found that current version is 2.8, so my version seems to be old. I attempted to install 2.8 from source but there were compiler errors as the Qt libraries on my system are too old for a recent qscintilla. Attempts to install a recent Qt from source resulted in complaints about other libraries...
I can deactivate code completion in the preferences, so I can continue using the new GUI without code completion until updated packages for qscintilla are available for SL.
Thanks again and regards,

Dirk

Anonymous
Sat 25 Jan 2014 11:01:21 PM UTC, comment #2: 

I agree with Torsten, it works for me, I can continue typing or erase characters with the completion box displayed. I can use the arrow keys to select one of the items in the completion box, or type another character to jump to the next one, or backspace to erase the text typed so far.

Mike Miller <mtmiller>
Project Administrator
Sat 25 Jan 2014 04:10:29 PM UTC, comment #1: 

It is not intended and "usually" not the case that the box with completion suggestions blocks further keyboard input.
Could you please post the exact preferences you are using? On what system are you running Octave and what is the version of your QScintilla-Libs?

Torsten Lilge <ttl>
Project Member
Sat 25 Jan 2014 02:22:59 PM UTC, original submission:  

Hi,
when using the Octave GUI I opened a new file t1.m in the text editor and attempted to type a line:

x = linspace(0,2*pi,201);

After typing "x = li" a code completion box comes up containing "line" and "link" but not the "linspace" I'd like to have.
Unfortunately all my further keyboard input is ignored unless I do a mouse click outside that selection box. After typing the next character "n" the suggestion box is coming up again, no keyboard input is accepted. So I have to take the hand off the keyboard two times while entering this line just to get rid of the suggestion box.
So my temporary solution is to turn code completion off.

Generally I consider code completion a good idea. While showing the suggestion list the editor should continue accepting keyboard input and shrink/hide the list as the user types more text or manually completes the word.

Regards,

Dirk

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by mtmiller (Posted a comment)
  • -email is unavailable- added by ttl (Posted a comment)
  • -email is unavailable- added by None (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-02-07 mtmiller StatusConfirmed => Wont Fix
        Open/ClosedOpen => Closed
    2014-01-28 mtmiller StatusWorks For Me => Confirmed
        SummaryGUI editor stops accepting keyboard input when showing code completion list box => GUI editor code completion popup blocks keyboard input on RHEL 6
    2014-01-25 mtmiller StatusNone => Works For Me

    Back to the top


    Powered by Savane 3.5