bugGNU Octave - Bugs: bug #41088, add a splash screen (loading is...

 
 

bug #41088: add a splash screen (loading is non-instantaneous)

Submitter:  Felipe G. Nievinski <fgnievinski>
Submitted:  Fri 03 Jan 2014 05:03:32 PM UTC
 
Category:  GUI Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Feature Request
Status:  Wont Fix Assigned to:  None
Originator Name:  Open/Closed:  * Closed
Release:  * 3.8.0 Operating System:  * Microsoft Windows
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

( Jump to the original submission )

Fri 22 Jul 2016 09:49:34 PM UTC, comment #11: 

Does anyone still think Octave should have a splash screen?

Startup of the GUI seems very fast to me, so I'm not sure that one is needed.  But I have a fairly fast computer so maybe startup speed is significantly slower for others.

For me, the splash screen is probably only on the screen for less than a second, so it seems like it would be better if it we could force it to be displayed for a minimum time of at least 2-3 seconds.  Otherwise it just seems annoying that it disappears too quickly to even see what it says.

If others think it would be good to have a splash screen, we can work from the updated version of the patch that I've attached.  Otherwise, could this report be closed?

(file #37991)

John W. Eaton <jwe>
Project Administrator
Thu 26 Feb 2015 12:15:33 AM UTC, comment #10: 

I've got an older computer so it shows up longer :)

John Donoghue <lostbard>
Project Member
Wed 25 Feb 2015 11:36:06 PM UTC, comment #9: 

The patch displays the sombrero logo, but it is only up for a very, very short time.  On Linux, it either flashes or doesn't show up at all because the time to load is so quick.

On Windows, octave.bat starts a command window which shows up and there is a wait, before a quick view of the sombrero logo and then the GUI main window appears.

I would like to get rid of the empty command window showing up on Windows that just sits there for a few seconds.  I'll take that up on bug #41074.

Rik <rik5>
Project Administrator
Wed 25 Feb 2015 08:45:51 PM UTC, comment #8: 

I'm going to test the patch for a Windows splashscreen today.

Rik <rik5>
Project Administrator
Mon 23 Feb 2015 12:01:43 AM UTC, comment #7: 

Heres an initial attempt for splashscreen when we get that far (attached)

I have created Windows QT applications before that dont show the terminal by specifying "-Wl,-subsystem,windows" in the LDFLAGS.

I have been meaning to try it to see if it will work in this case, but hadnt gotten around to it.

(file #33153)

John Donoghue <lostbard>
Project Member
Tue 10 Feb 2015 05:40:12 PM UTC, comment #6: 

As noted in bug #41074, we sort of do have a splash screen on Windows systems because the console window is shown initially, and that shows up pretty much immediately after Octave is started.  :-)

But if loading is slow on Windows systems and someone finds a way to avoid showing the initial terminal window (or we rework the command window widget so there is no hidden windows console/terminal thing at all) then I would not object to a splash screen of some kind.

John W. Eaton <jwe>
Project Administrator
Tue 10 Feb 2015 05:27:33 PM UTC, comment #5: 

Linking in the related bug #41074.

Rik <rik5>
Project Administrator
Tue 10 Feb 2015 05:26:13 PM UTC, comment #4: 

Particularly on Windows systems, I do find the lack of a splash screen a problem.  jwe doesn't want one for Linux which is fine.  Can we code apply the patch from Felipe protected by and #ifdef for Windows systems? 

Rik <rik5>
Project Administrator
Sat 04 Jan 2014 10:45:22 AM UTC, comment #3: 

On Linux systems the loading time is too short for a splash screen. On windows (especially without the empty cmd-window, bug #41074) the user really might be wondering whether the program is loading or not. Should we offer an option in the settings for the splash-screen which is off by default?

Torsten Lilge <ttl>
Project Member
Fri 03 Jan 2014 05:30:33 PM UTC, comment #2: 

I think it's a (good) feature that Octave doesn't have a splash screen, not a bug.

John W. Eaton <jwe>
Project Administrator
Fri 03 Jan 2014 05:06:45 PM UTC, comment #1: 
Felipe G. Nievinski <fgnievinski>
Fri 03 Jan 2014 05:03:32 PM UTC, original submission:  

patch to come

Felipe G. Nievinski <fgnievinski>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #37991:  splashscreen.patch added by jwe (79KiB - text/x-patch)
file #33153:  splashscreen.patch added by lostbard (79KiB - text/x-patch)
file #30176:  splash.diff added by fgnievinski (1KiB - application/octet-stream)

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by lostbard (Updated the item)
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by ttl (Posted a comment)
  • -email is unavailable- added by jwe (Posted a comment)
  • -email is unavailable- added by fgnievinski (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 7 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-09-21 rik5 StatusPatch Submitted Wont Fix
        Open/ClosedOpen Closed
    2016-07-22 jwe Attached File- Added splashscreen.patch, #37991
    2015-02-23 lostbard Attached File- Added splashscreen.patch, #33153
    2015-02-10 rik5 Dependencies- Depends on bugs #41074
    2015-02-10 rik5 StatusNone Patch Submitted
    2014-01-03 fgnievinski Attached File- Added splash.diff, #30176

    Back to the top


    Powered by Savane 3.9