bugGNU Octave - Bugs: bug #40588, set(gca, 'xaxislocation', 'zero')...

 
 

bug #40588: set(gca, 'xaxislocation', 'zero') has no effect

Submitter:  Muhali <muhali>
Submitted:  Fri 15 Nov 2013 01:16:49 PM UTC
 
Category:  Plotting with OpenGL Severity:  3 - Normal
Priority:  5 - Normal Item Group:  None
Status:  Wont Fix Assigned to:  None
Originator Name:  Open/Closed:  * Closed
Release:  * dev Operating System:  * GNU/Linux
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

( Jump to the original submission )

Tue 19 Jul 2016 03:08:07 PM UTC, comment #8: 

@Markus: Go ahead and file a new bug report.  I suppose it can be now be a Matlab Compatibility item.

Rik <rik5>
Project Administrator
Tue 19 Jul 2016 02:10:53 PM UTC, comment #7: 

In recent Matlab versions, it is possibelsetting "xaxislocation" to "origin" which does essentially the same what gnuplot does when it is set to "zero" [1].

Since the original report was about letting the axis cross "0", can this bug be reopened (and re-titled) for the implementation of "origin"?
Or should I file a new bug report?

[1] http://de.mathworks.com/help/matlab/examples/controlling-axis-location.html

Markus M├╝tzel <mmuetzel>
Project Member
Wed 25 Jun 2014 04:49:36 PM UTC, comment #6: 

I would create a new Wish List issue report to cover the case of adding OpenGL support for a "zero" location.  Include the possible justification that it is a differentiating feature that other open source programs like R have over Matlab.

Rik <rik5>
Project Administrator
Wed 25 Jun 2014 04:30:27 PM UTC, comment #5: 

>> The only use for 'xaxislocation', 'zero' is in polar plots and a patch has been submitted for creating a polar grid. Closing report.


Googling images for 'multidimensional scaling' one finds numerous cases of non-polar plots with a central x-axis. That is just one of many examples, basically all cases with a symmetry of x or y about 0. They all speak in favor of having set(gca, 'xaxislocation', 'zero').

Here is another prominent place:

http://en.wikipedia.org/wiki/Cartesian_coordinate_system

ML doesn't have that feature but it is often requested (see e.g. PlotAxisAtOrigin, oaxes, axescenter). R has it, GeoGebra has it.

Muhali <muhali>
Wed 25 Jun 2014 03:05:36 PM UTC, comment #4: 

The "zero" location can be removed from Octave (and the demos that test it).  It was only done to help with the implementation of polar() for gnuplot.  Since we have a much better implementation of polar now this isn't required.  The feature was never documented because it does differ from Matlab and was meant only for internal use.

Rik <rik5>
Project Administrator
Wed 25 Jun 2014 08:19:56 AM UTC, comment #3: 

If we decide to not implement x-/yaxislocation 'zero' for the fltk toolkit, what are the plans with qt? Btw, 'zero' is not documented in doc/interpreter/plot.txi:1784, only 'top' and 'bottom'.

Some demos for 'axis' (NR 9..13) makes use of x-/yaxislocation 'zero', which apparently doesn't work with the, now default, fltk toolkit. Should we remove these demos?

Background:
I'm trying to make the plot demos executable by matlab to create plots for comparison and found this issue (?axislocation 'zero' not allowed in ML).

Andreas Weber <andy1978>
Project Member
Wed 30 Apr 2014 01:33:29 AM UTC, comment #2: 

This issue doesn't require fixing.  The only use for 'xaxislocation', 'zero' is in polar plots and a patch has been submitted for creating a polar grid.  Closing report.

Rik <rik5>
Project Administrator
Sat 16 Nov 2013 02:15:09 PM UTC, comment #1: 

This is a known difference between the gnuplot and fltk toolkits.  With gnuplot, we use 'xaxislocation', 'zero' when doing polar plots.  I've changed the category to "Plotting with OpenGL".  This isn't a compatibility problem, Matlab doesn't have this option.  And we don't even need to support it for the FLTK toolkit if we had a way of drawing the background axis for a polar plot correctly.  There is already a bug report filed on that (bug #39495)

Rik <rik5>
Project Administrator
Fri 15 Nov 2013 01:16:49 PM UTC, original submission:  

I suppose set(gca, 'xaxislocation', 'zero') should put the x-axis at y = 0. This does not work. Note that ML does not allow 'zero' for this property (only 'top' and 'bottom').

Same with yaxislocation.

Muhali <muhali>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mmuetzel (Posted a comment)
  • -email is unavailable- added by andy1978 (Posted a comment)
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by muhali (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2014-04-30 rik5 StatusConfirmed Wont Fix
        Open/ClosedOpen Closed
    2013-11-16 rik5 CategoryPlotting Plotting with OpenGL
        StatusNone Confirmed
    2013-11-16 rik5 Dependencies- Depends on bugs #39495

    Back to the top


    Powered by Savane 3.9