bugGNU Octave - Bugs: bug #40347, figure () fails when called from...

 
 

bug #40347: figure () fails when called from script file

Submitter:  Torsten Lilge <ttl>
Submitted:  Tue 22 Oct 2013 04:24:49 PM UTC
 
Category:  Plotting Severity:  5 - Blocker
Priority:  5 - Normal Item Group:  Regression
Status:  Invalid Assigned to:  None
Originator Name:  Open/Closed:  * Closed
Release:  * dev Operating System:  * GNU/Linux
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Tue 22 Oct 2013 06:04:54 PM UTC, comment #3: 

Uh oh, I accidentally have created a file max.m in my home direcroy while testing for another bug. This file caused the trouble.
I apologize for the noise!

Torsten Lilge <ttl>
Project Member
Tue 22 Oct 2013 05:40:40 PM UTC, comment #2: 

Sorry, here the missing infos:

  • hg revision 17725:3f02bcf2bdcc
  • The issue occurs
    • on the cli and gui version,
    • also when starting octave with -f,
    • and only with fltk as graphics backend
Torsten Lilge <ttl>
Project Member
Tue 22 Oct 2013 04:49:14 PM UTC, comment #1: 

This works for me.  I created a script, junk.m, with the single command "figure;" in it.  On the command line, executing 'junk' creates a new figure.

What hg revision are you using?  Is this GUI or CLI version?  Did you try 'run-octave -f' to skip reading all initialization files?  Sometimes there is something in one's .octaverc file that is the real problem.

Rik <rik5>
Project Administrator
Tue 22 Oct 2013 04:24:49 PM UTC, original submission:  

Whereas evaluating the command figure () from the console works as expected, evaluating a script that only contains

figure();

leads to

warning: max: some elements in list of return values are undefined
error: reshape: can't reshape 1x1 array to 0x0 array
error: called from:
error:   /home/ttl/software/octave/.build/../scripts/general/repmat.m at line 95, column 9
error:   /home/ttl/software/octave/.build/../scripts/general/shift.m at line 61, column 7
error:   /home/ttl/software/octave/.build/../scripts/plot/util/findobj.m at line 194, column 21
error:   /home/ttl/software/octave/.build/../scripts/plot/util/findall.m at line 45, column 7
error:   /home/ttl/software/octave/.build/../scripts/plot/util/private/__add_default_menu__.m at line 34, column 7
error:   /home/ttl/software/octave/.build/../scripts/plot/util/figure.m at line 96, column 5
error:   /home/ttl/tst.m at line 1, column 1

After that, figure () directly called from the console throws the same errors.

Torsten Lilge <ttl>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by rik5 (Posted a comment)
  • -email is unavailable- added by ttl (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2013-10-22 ttl StatusWorks For Me Invalid
        Open/ClosedOpen Closed
    2013-10-22 rik5 StatusNone Works For Me

    Back to the top


    Powered by Savane 3.9