bugGNU Octave - Bugs: bug #40301, MinGW/MXE - urlwrite won't load,...

 
 

bug #40301: MinGW/MXE - urlwrite won't load, but urlread does.

Submitted by:  Philip Nienhuis <philipnienhuis>
Submitted on:  Fri 18 Oct 2013 09:29:37 AM UTC  
 
Category:  Octave Function Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Regression
Status:  Invalid Assigned to:  None
Originator Name:  Philip Nienhuis Open/Closed:  Closed
Release:  dev Operating System:  Microsoft Windows

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sat 19 Oct 2013 09:26:39 PM UTC, comment #5: 

Thanks! You'e right, I still had the oct file lying around.

I overlooked that the temporary install dir in mxe-octave (where a freshly compiled octave is installed before its contents are copied to the dist subdir) isn't cleaned up upon a new build of octave. Another improvement to make in mxe, I'll try to look into that as well.

I'll close this bug.

Philip Nienhuis <philipnienhuis>
Project Member
Sat 19 Oct 2013 04:46:40 PM UTC, comment #4: 

When I made those changes, I also made urlread and urlwrite built-in functions instead of .oct files.  So I suspect that you still have the old .oct file from a previous build.  If, so try removing that and I think it will work.

John W. Eaton <jwe>
Project Administrator
Sat 19 Oct 2013 03:41:06 PM UTC, comment #3: 

Maybe this cs is related:
17555:0946b0e06544  move url_transfer classes to liboctave

I got some more info. Running "help urlwrite" in octave-cli.exe gives a pop-up window:

"The procedure entry point _ZN19unwind_protect_safe15gripe_exceptionEv could not be located in the dnamic link library liboctinterp-1.dll"

Could it be a miscompiled urlwrite.cc?

Philip Nienhuis <philipnienhuis>
Project Member
Sat 19 Oct 2013 02:56:51 PM UTC, comment #2: 

I wonder whether one of these changesets from Oct 7 are related:

- 17595:4b65355a31f2  avoid some code duplication in url-transfer ftp methods

- 17596:43b9181340fb  separate object creation from http actions in url_transfer class

- 17597:e5932e528721  url-transfer.cc (base_url_transfer::mput_directory): Return file list

- 17598:d8d71c89fff2  eliminate unnecessary member variable in url_base_transfer class

This date fits in the time window when urlwrite() stopped working here.

BTW does mkoctfile work for you on Windows? Since yesterday or day before it doesn't work anymore.
AFAICS it is a similar problem: a mkoctfile-3.7.7+.exe from Oct 16 works OK, while the very same (byte size) mkoctfile-3.7.7+.exe from Oct 18 stops with:

>> mkoctfile csv2cell.cc
mkoctfile: no way to compile C++ file csv2cell.cc
warning: mkoctfile exited with failure status
>>

Philip Nienhuis <philipnienhuis>
Project Member
Sat 19 Oct 2013 11:12:32 AM UTC, comment #1: 

My mxe build from 2013-10-14 works fine.
But there are some changes in the last days, so i'll going to rebuild.

--Markus

Anonymous
Fri 18 Oct 2013 09:29:37 AM UTC, original submission:  

Since a while urlwrite doesn't get loaded in MXE builds for Windows. (I stumbled on this only because I found "pkg -forge" doesn't work anymore; these days I usually invoke build_packages.m in the <mxe>/src subdir.)

Interestingly, urlread (in the same .oct file "urlwrite.oct") does work.

In an older 3.7.6+ MXE (mid September) it works fine.
I tried copying over urlwrite.oct from that 3.7.6+ to 3.7.7+ but that made no difference (to be expected as they're the exact same byte size).
Makes me wonder: is it something autoload related?

>> which urlwrite
error: __which__: library open failed: X:\Octave\octave-2013-10-16-21-38\lib\octave\3.7.7+\oct\i686-pc-mingw32\urlwrite.oct
error: called from:
error:   X:\Octave\octave-2013-10-16-21-38\share\octave\3.7.7+\m\help\which.m at line 29, column 7

but

>> which urlread
'urlread' is a built-in function from the file libinterp/corefcn/urlwrite.cc
>>

Philip Nienhuis <philipnienhuis>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by jwe (Posted a comment)
  • -email is unavailable- added by philipnienhuis (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only project members can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2013-10-19 philipnienhuis StatusNone => Invalid
        Open/ClosedOpen => Closed

    Back to the top


    Powered by Savane 3.5