bugGNU Octave - Bugs: bug #39761, imread() crashes octave

 
 

bug #39761: imread() crashes octave

Submitter:  Ben Abbott <bpabbott>
Submitted:  Sun 11 Aug 2013 03:51:07 PM UTC
 
Category:  None Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Regression
Status:  Duplicate Assigned to:  None
Originator Name:  Ben Abbott Open/Closed:  * Closed
Release:  * dev Operating System:  * Mac OS
Fixed Release:  None Planned Release:  None
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Sun 01 Sep 2013 08:37:05 PM UTC, comment #2: 

I've been using Macports and built GraphicsMagick with the "+q8" variant.   When I change the variant to +q16, "test imread" passes for me.

Ben Abbott <bpabbott>
Project Member
Sun 11 Aug 2013 04:08:44 PM UTC, comment #1: 

Duplicate of bug #39698

Carnë Draug <carandraug>
Project Member
Sun 11 Aug 2013 03:51:07 PM UTC, original submission:  

test imread
warning: your version of GraphicsMagick limits images to 8 bits per pixel
octave(20194,0x7fff74e44960) malloc: *** error for object 0x7fff75650860: pointer being freed was not allocated
*** set a breakpoint in malloc_error_break to debug

Looks like a recent regression, but after a quick glance, I didn't identify a likely changeset

Ben Abbott <bpabbott>
Project Member

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by bpabbott (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2013-08-11 carandraug StatusNone Duplicate
        Open/ClosedOpen Closed

    Back to the top

    Powered by Savane 3.9