bugGNU Octave - Bugs: bug #39549, ytick property and display...

 
 

bug #39549: ytick property and display different when ytickmode = "auto" (gnuplot)

Submitter:  None
Submitted:  Mon 22 Jul 2013 02:17:10 PM UTC
   
 
Category:  Plotting with gnuplot Severity:  3 - Normal
Priority:  3 - Low Item Group:  Incorrect Result
Status:  Confirmed Assigned to:  None
Originator Name:  Originator Email:  -email is unavailable-
Open/Closed:  * Open Release:  * dev
Operating System:  * Any Fixed Release:  None
Planned Release:  None
* Mandatory Fields

Add a New Comment Rich Markup
   

Mon 21 Nov 2016 10:26:53 PM UTC, comment #3: 

This (gnuplot) issue is still the same in Octave 4.2.0.

Hartmut <hardy>
Thu 04 Jun 2015 01:52:13 AM UTC, comment #2: 

Still present in the development version of Octave with a current version of gnuplot. Does not affect the OpenGL plotting backends that are rendering the axes themselves.

Mike Miller <mtmiller>
Group Member
Tue 13 Aug 2013 05:38:46 PM UTC, comment #1: 

The problem is only with gnuplot.  The issue is that the "ytickmode" property is set to "auto".  In this case, Octave calculates ytick values, but so does gnuplot.  Ideally, only Octave should calculate the ytick values and pass them down to gnuplot so that the display remains in sync with what Octave believes is being displayed.

This one-liner is a workaround you can use until this gets fixed.  It grabs the current ytick values that Octave knows about, and then sets them on the current axis.  This forces the "ytickmode" to "manual" and installs the ytick values that Octave knows about.


set (gca, "ytick", get (gca, "ytick"));


Rik <rik5>
Group administrator
Mon 22 Jul 2013 02:17:10 PM UTC, original submission:  

I can't really tell in which cases this happens, but I have an example that does return wrong tick values reliably for me:

> plot(0:4)
> get(gca, 'ytick')
ans =

   0   1   2   3   4
> get(gca, 'xtick')
ans =

   1   2   3   4   5

There are ticks at 0.5, 1.5 etc. in the plot, so the expected and correct results would be:

> get(gca, 'ytick')
ans =

    0.00000    0.50000    1.00000    1.50000    2.00000    2.50000    3.00000    3.50000    4.00000
> get(gca, 'xtick')
ans =

    1.0000    1.5000    2.0000    2.5000    3.0000    3.5000    4.0000    4.5000    5.0000


Plotting 0:3 works fine and so does 0:5.
1:5 and 0:2:8 both have the same issue.

I'm running Octave 3.6.2 with Gnuplot 4.6 patchlevel 0 on Debian Wheezy. More specifically, I have these octave packages installed:
liboctave1 (3.6.2-5+deb7u1, amd64)
octave (3.6.2-5+deb7u1, amd64)
octave-common (3.6.2-5+deb7u1, all)
octave-htmldoc (3.6.2-5+deb7u1, all)
octave-info (3.6.2-5+deb7u1, all)
octave-io (1.0.19-1, amd64)
octave-java (1.2.8-6, amd64)
octave-miscellaneous (1.1.0-1, amd64)
octave-nan (2.5.5-2, amd64)
octave-octcdf (1.1.4-2, amd64)
octave-plot (1.1.0-2, all)
octave-statistics (1.1.3-1, all)
octave-strings (1.1.0-1, amd64)

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one

Digest:
   bug dependencies.

 

Carbon-Copy List
  • -email is unavailable- added by hardy (Posted a comment)
  • -email is unavailable- added by rik5 (Posted a comment)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only group members can vote.

     

    Follow 7 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-03-11 mtmiller Carbon-CopyRemoved 80942 -
    2015-12-10 mtmiller Dependencies- bugs #46617 is dependent
    2015-06-04 mtmiller Priority5 - Normal 3 - Low
        Release3.6.2 dev
        Operating SystemGNU/Linux Any
    2013-08-13 rik5 StatusNone Confirmed
        SummaryAxis tick properties carry incorrect values in some cases ytick property and display different when ytickmode = "auto" (gnuplot)

    Back to the top

    Powered by Savane 3.13-758e.
    Corresponding source code