bugGNU Octave - Bugs: bug #37798, datevec('25.03.2001 02:00:00',...

 
 

bug #37798: datevec('25.03.2001 02:00:00', 'dd.mm.yyyy HH:MM:SS') ??

Submitter:  Muhali <muhali>
Submitted:  Fri 23 Nov 2012 05:43:33 PM UTC
 
Category:  None Severity:  3 - Normal
Priority:  5 - Normal Item Group:  Incorrect Result
Status:  Duplicate Assigned to:  None
Originator Name:  Open/Closed:  * Closed
Release:  * dev Operating System:  * GNU/Linux
Fixed Release:  None Planned Release:  None
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Sun 25 Nov 2012 07:28:12 PM UTC, comment #2: 

However, consider this:

datenum('2001-03-25 02:00:00'), datenum([2001 03 25 2 0 0])

ans =  730935.125000000
ans =  730935.083333333

which may or may not be related to bug #36954

Muhali <muhali>
Fri 23 Nov 2012 05:50:59 PM UTC, comment #1: 

Duplicate of bug #36954

Jordi GutiƩrrez Hermoso <jordigh>
Project Administrator
Fri 23 Nov 2012 05:43:33 PM UTC, original submission:  

datevec('25.03.2001 02:00:00', 'dd.mm.yyyy HH:MM:SS')

Interestingly, the answer is

ans =

   2001      3     25      3      0      0

which is not what one would expect and not what ML gives. Is it because the 'dd.mm.yyyy HH:MM:SS' format string is not among those mentioned in the datestr help?

Muhali <muhali>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

No files currently attached

 

Digest:
   bug dependencies.

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by jordigh (Posted a comment)
  • -email is unavailable- added by muhali (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only project members can vote.

     

     

     

     

    Follow 3 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2012-11-23 jordigh Dependencies- Depends on bugs #36954
    2012-11-23 jordigh StatusNone Duplicate
        Open/ClosedOpen Closed

    Back to the top

    Powered by Savane 3.9