helpSavannah Administration - Support: sr #109197, Savannah password not working...

 
 

sr #109197: Savannah password not working before verification

Submitted by:  None
Submitted on:  Thu 08 Dec 2016 01:45:43 PM UTC  
 
Category: NonePriority: 5 - Normal
Severity: 3 - NormalStatus: Done
Assigned to: Bob Proulx <rwp>Originator Email: -unavailable-
Operating System: GNU/LinuxOpen/Closed: Closed

Add a New Comment(Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Wed 26 Apr 2017 03:42:14 AM UTC, comment #2:

Hello,

I see that the user has been able to activate the account ( https://savannah.gnu.org/u/willemmali , marked as 'active' in the database).

If there are still login problems - the "password reset" can be used (since the email is verified).

I'm closing this item, but if there are more issues related to this account - please let us know.

regards,
- assaf

Assaf Gordon <agn>
Site Administrator
Fri 09 Dec 2016 10:47:57 PM UTC, comment #1:

Good that you have received the account activation link. Good that you have used it to verify your email. However it hasn't been logged that this action has occurred yet. The system still lists you as pending and wants you to verify your email.

You say you are getting an invalid password error when clicking the activation link. That leads me to believe that the activation link is getting mangled in the email somehow.

As far as I can tell using a 20 character password containing the special characters you listed should be okay. I performed a test just now on the system's pwqcheck and I was able to use such types of passwords okay.

Which leaves me at a loss to know what the problem is at this time. If you think it might be related to using LastPass (although I think it should be okay) then I suggest avoiding it for the initial account activation step just so far as to activate your account. Then use LastPass afterward to reset your password.

I will assign this ticket to me since I am responding and I don't want it to languish without a response however I admit to being at a loss here. Perhaps one of the other volunteer admins will know of a better plan and will feel free to jump in. Until then I will wait for feedback on this next attempt.

Bob Proulx <rwp>
Site AdministratorIn charge of this item.
Thu 08 Dec 2016 01:45:43 PM UTC, original submission:

I just registered a Savannah account, but I can't get verified. I click the verification link in the email I received, but I got an invalid password error. I know I have the right password because it was generated, saved and entered into both the registration form and the login form, by LastPass.

My setup:

Debian Testing amd64 multiarch
Chromium 53.0.2785.143 for amd64
uMatrix (whitelisted all requests on all relevant pages), LastPass installed

My LastPass auto generated passwords tend to find bugs in registration/login forms. I use a 20 char password containing these special characters:

!$^&

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by agn (Posted a comment)
  • -unavailable- added by rwp (Posted a comment)
  • -unavailable- added by rwp
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 5 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Wed 26 Apr 2017 03:42:14 AM UTCagnStatusNeed Info=>Done
      Open/ClosedOpen=>Closed
    Fri 09 Dec 2016 10:47:57 PM UTCrwpStatusNone=>Need Info
      Assigned toNone=>rwp
      Carbon-Copy-=>Added -unavailable-

    Back to the top


    Powered by Savane 3.1-cleanup1