helpGNU TeXmacs - Support: sr #108662, Broken link when saving new file

 
 

You are not allowed to post comments on this tracker with your current authentication level.

sr #108662: Broken link when saving new file

Submitted by:  Punto Di Rosso <puntodirosso>
Submitted on:  Fri 10 Oct 2014 10:21:02 AM UTC  
 
Category:  None Priority:  5 - Normal
Severity:  2 - Minor Status:  None
Privacy:  Public Assigned to:  None
Open/Closed:  Open Operating System:  GNU/Linux

Fri 10 Oct 2014 10:21:02 AM UTC, original submission:  

The "linking image" uses relative paths. When changing saving a .tm file containing the link to the image to another directory, the link is broken and the image is replaced by the question mark place holder.
I understand that using relative path in linking is a very useful as it is easier to move projects into other directories/systems.

The situation is problematic when creating a new file in TeXmacs and linking an image to that file before saving the file.
When saving the file to some folder, the link gets broken in the process.

I think this is worth considering handling that case and set a the directory to a TeXmacs file only when it has been saved.

Also it might be interesting to have an option to change link into absolute paths. I could not find this. I don't know if it exists. I tried to search the help for "image" and "linking image" but did not find any mention of such an option.

Punto Di Rosso <puntodirosso>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by puntodirosso (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    No changes have been made to this item

    Back to the top


    Powered by Savane 3.5