helpGNU Libtool - Support: sr #100409, install & clean broken on...


sr #100409: install & clean broken on cygwin

Submitted by:  Yann Dirson <ydirson>
Submitted on:  Fri 08 Feb 2002 05:01:09 PM UTC  
Category: NonePriority: 5 - Normal
Severity: 2 - MinorStatus: None
Privacy: PublicAssigned to: None
Open/Closed: OpenOperating System: None

Add a New Comment (Rich MarkupRich Markup):

You are not logged in

Please log in, so followups can be emailed to you.


Fri 08 Feb 2002 05:01:09 PM UTC, original submission:

The following make rules do not work:

foo: foo.o
libtool gcc foo.o -o foo

install: foo
libtool cp foo /usr/bin

libtool --mode=clean rm foo foo.o

Both the install and clean rules fail with "foo: no
such file or dir". File "foo" does not exist because
we did not link with a libtool lib, and I only have

OTOH, "libtool install" works fine, but is not portable
on platforms without a BSD install (eg. Solaris).

It works fine for executables that link to a
libtool-built shared lib, though.

Yann Dirson <ydirson>


(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):

No files currently attached


Depends on the following items: None found

Items that depend on this one: None found


CC list is empty


Do you think this task is very important?
If so, you can click here to add your encouragement to it.
This task has 0 encouragements so far.

Only logged-in users can vote.


Please enter the title of George Orwell's famous dystopian book (it's a date):



No Changes Have Been Made to This Item

Back to the top

Powered by Savane 3.1-cleanup