patchPSPP - Patches: patch #8549, Startup Notification does not work

 
 

You are not allowed to post comments on this tracker with your current authentication level.

patch #8549: Startup Notification does not work

Submitted by:  Friedrich Beckmann <beckmanf>
Submitted on:  Sun 05 Oct 2014 08:11:50 PM UTC  
 
Category:  None Item Group:  None
Status:  Done Assigned to:  None
Open/Closed:  Closed

Mon 25 May 2015 08:49:45 AM UTC, comment #5:
Friedrich Beckmann <beckmanf>
Project Member
Sun 05 Oct 2014 10:26:42 PM UTC, comment #4:

Hi John,

I tried it in a testing environment. I could see the problem in KDE right away. I could see the problem in GNOME if I enable the startup notification with StartupNotify=true explicitly. So I guess there is something not working.

Can you see the startup notification working by some hourglass or bouncing symbol in your environment?

In my setup (debian testing) I can see the bouncing symbol which does not disappear.

Friedrich

Friedrich Beckmann <beckmanf>
Project Member
Sun 05 Oct 2014 09:47:16 PM UTC, comment #3:

This always works properly for me.  I suspect there is something unusual about the reporter's environment.

Startup notification works by default in GTK.  We only worry about it for the splash window, because the appearance of the splash screen does not indicate the program has started.

It is therefore disabled for the splash screen, but enabled for all others.

John Darrington <jmd>
Project Administrator
Sun 05 Oct 2014 09:38:39 PM UTC, comment #2:

I only googled a bit. If there is only one window it should work automatically by gtk. But   for other (o.k which?) conditions it has be done manually with:

https://developer.gnome.org/gdk3/stable/gdk3-General.html#gdk-notify-startup-complete

But this is just google result...

Friedrich Beckmann <beckmanf>
Project Member
Sun 05 Oct 2014 08:18:01 PM UTC, comment #1:

Applied to master, thanks!

> Once startup notification is implemented, this needs to be changed back. The problem for the user is that the bouncing symbol does not stop even when pspp has loaded.


Do you know how to implement startup notification?  I do not.

Ben Pfaff <blp>
Project Administrator
Sun 05 Oct 2014 08:11:50 PM UTC, original submission:

Rony Standtke figured out a bug regarding startup notification behavior. The bug description is in the debian bug tracker here:

https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=763603

The problem is that pspp currently does not provide startup notification feedback. As long as the notification does not work, this should be indicated in the desktop entry. The attached patch sets

StartupNotify=false

in the final file pspp.desktop.

Once startup notification is implemented, this needs to be changed back. The problem for the user is that the bouncing symbol does not stop even when pspp has loaded.

Friedrich Beckmann <beckmanf>
Project Member

 

Attached Files
file #32228:  startupnotify.patch added by beckmanf (742B - application/octet-stream - patch to switch off startup notification)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by jmd (Posted a comment)
  • -email is unavailable- added by blp (Posted a comment)
  • -email is unavailable- added by beckmanf (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2015-05-25 beckmanf Open/ClosedOpen => Closed
    2014-10-05 jmd Open/ClosedClosed => Open
    2014-10-05 blp StatusNone => Done
        Open/ClosedOpen => Closed
    2014-10-05 beckmanf Attached File- => Added startupnotify.patch, #32228

    Back to the top


    Powered by Savane 3.4