newsGNU Libtool - News: GNU Libtool 2.4 released [stable]

 
 
Latest News
GNU libtool-2.4.4 released [stable] posted by gary, Sat 29 Nov 2014 06:21:33 PM UTC - 0 replies
GNU libtool 2.4.3 released [stable] posted by gary, Mon 27 Oct 2014 08:11:41 PM UTC - 0 replies
libtool-2.4.2.418 released [alpha] posted by gary, Sun 27 Oct 2013 12:51:14 AM UTC - 0 replies
GNU Libtool 2.4.2 released [stable] posted by gary, Tue 18 Oct 2011 09:59:19 AM UTC - 0 replies
GNU Libtool 2.4 released [stable] posted by gary, Wed 22 Sep 2010 04:02:17 PM UTC - 0 replies
[Submit News]
[14 news in archive]

GNU Libtool 2.4 released [stable]

Item posted by Gary V. Vaughan <gary> on Wed 22 Sep 2010 04:02:17 PM UTC.

Libtoolers!

The Libtool Team is pleased to announce the release of GNU Libtool 2.4.

GNU Libtool hides the complexity of using shared libraries behind a
consistent, portable interface. GNU Libtool ships with GNU libltdl,
which hides the complexity of loading dynamic runtime libraries
(modules) behind a consistent, portable interface.

New in 2.4 2010-09-22:

  • New features:

- Sysroot support. This allows you to build cross-compiled packages
with the same prefix that will be used on the destination machine,
and still find dependent libraries under the compiler's "sysroot".
Without sysroot support, paths internal to the build system may leak
into the product of the build.

Sysroot support is disabled unless the --with-sysroot configure
option is passed to configure, because .la files generated with
sysroot support will not be usable in general with older Libtools.

- On non-cygwin Windows systems, we now lookup potential library
file names without regard to file name case.
- The old testsuite now uses the `parallel-tests' Automake test driver
now for more concurrency and better test logging. For this, tests are
run in verbose mode by default now.

  • Important incompatible changes:

- Autoconf 2.62 and Automake 1.11.1 or newer are now required for
bootstrapping Libtool. For using Libtool in your own projects,
Autoconf 2.59 and Automake 1.9.6 should still work.
- The fix_srcfile_path variable has been replaced by a more thorough
mechanism triggered by the to_tool_file_cmd variable.

  • Changes in supported systems or compilers:

- Initial support for the Microsoft C/C++ Compiler, with help from
the compile script in unreleased Automake 1.12. Override the manifest
tool used to embed the manifest resource through the environment
variable MANIFEST_TOOL. Please note that the import library naming
has changed (from foo-2.lib to foo.dll.lib) from when the code lived
in its own git branch.
- Initial support for the NAG Fortran compiler on GNU/Linux.

  • Bug fixes:

- The `check-interactive' and `check-noninteractive' convenience make
targets now also work for the old testsuite.
- Warnings from Autoconf v2.67-36-g1e604ec about incomplete programs
passed to AC_*_IFELSE tests have been fixed.
- On IRIX, the test for -Wl,-exported_symbol now also works with gfortran.

libtool-2.4 is available now from ftp.gnu.org, along with compressed diffs
against libtool-2.2.10. Please use a mirror to reduce stress on the main
gnu machine:

http://www.gnu.org/order/ftp.html

Here are the compressed sources:

ftp://ftp.gnu.org/gnu/libtool/libtool-2.4.tar.gz (2.5MiB)
ftp://ftp.gnu.org/gnu/libtool/libtool-2.4.tar.xz (883KiB)

Here are the compressed diffs against libtool 2.2.10:

ftp://ftp.gnu.org/gnu/libtool/libtool-2.2.10-2.4.diff.gz (655KiB)

Here are the gpg detached signatures:

ftp://ftp.gnu.org/gnu/libtool/libtool-2.2.4.tar.gz.sig (4.0KiB)
ftp://ftp.gnu.org/gnu/libtool/libtool-2.2.4.tar.xz.sig (4.0KiB)
ftp://ftp.gnu.org/gnu/libtool/libtool-2.2.10-2.4.diff.gz.sig (4.0KiB)RANCH@-@VERSION@.xdelta.sig

You should download the signature named after any tarball you download,
and then verify its integrity with, for example:

gpg --verify libtool-2.4.tar.gz.sig

Here are the MD5 and SHA1 checksums:

b32b04148ecdd7344abc6fe8bd1bb021 libtool-2.4.tar.gz
4e6144439d95d7332dc50ace6dd24c55 libtool-2.4.tar.xz
7bb66dc1df9d4e11160264847d905692 libtool-2.2.10-2.4.diff.gz
149e9d7a993b643d13149a94d07bbca1085e601c libtool-2.4.tar.gz
a5a44aa791c8b93cbe1c2f839368cd3de5f5f3e1 libtool-2.4.tar.xz
639b6c70f40c94d92c72cdad0381d5750ea41124 libtool-2.2.10-2.4.diff.gz

This release was bootstrapped with autoconf-2.67 and automake-1.11.1,
but is useable with autoconf-2.62 and automake-1.9.6 in your own
projects.

Alternatively, you can fetch the unbootstrapped source code with
git by using the following command:

$ git clone git://git.savannah.gnu.org/libtool.git
$ cd libtool
$ git checkout v2.4

You will then need to have the latest release versions of Automake
(automake-1.11.1) and Autoconf (autoconf-2.67) installed to
bootstrap the checked out sources yourself.

Please report bugs to <bug-libtool@gnu.org>, along with the verbose
output of any failed test groups, and the output from `./libtool --config.'
The README file explains how to capture the verbose test output.

Enjoy!

Comments:

No messages in GNU Libtool 2.4 released [stable]

 

Back to the top


Powered by Savane 3.1-cleanup