newsGNU Screen - News: Screen users mailing list

Latest News
GNU Screen v.4.6.1 posted by amade, Mon 10 Jul 2017 07:45:46 PM UTC - 0 replies
GNU Screen v.4.6.0 posted by amade, Wed 28 Jun 2017 07:01:57 PM UTC - 0 replies
GNU Screen v.4.5.1 posted by anaumov, Sun 26 Feb 2017 09:17:48 PM UTC - 0 replies
GNU Screen v.4.5.0 posted by anaumov, Tue 17 Jan 2017 08:46:37 PM UTC - 0 replies
GNU Screen v.4.3.1 posted by amade, Sun 28 Jun 2015 10:01:54 PM UTC - 0 replies
[Submit News]
[12 news in archive]

Screen users mailing list

Item posted by Juergen Weigert <jnweiger> on Fri 28 May 2004 12:37:45 PM UTC.

The mailing list, archived at is active again.

Screen 4.00.03, frozen, can't reattach (posted by Timothy Miller, Sat 20 Nov 2010 10:19:33 PM UTC)

When using gnu screen, I'm in the habit of just dropping the connection (I'll put my laptop to sleep, for example), and periodically, I have screen just refuse to allow me to reattach. I've tried to do some research on this.

This guy claims to have submitted a patch to fix it:

While this thread claims that there is no good fix:

I've tried all sorts of things to get it unstuck. Attaching/detaching a debugger, various command-line options, sending signals, etc. Nothing works.

My situation seems different from the 2009 thread, because I'm not stuck in write(). Here's what the debugger tells me:

0x00007f59953073c3 in __select_nocancel () at ../sysdeps/unix/syscall-template.S:82
82 ../sysdeps/unix/syscall-template.S: No such file or directory.
in ../sysdeps/unix/syscall-template.S
(gdb) where
#0 0x00007f59953073c3 in __select_nocancel () at ../sysdeps/unix/syscall-template.S:82
#1 0x0000000000441ccc in sched () at sched.c:124
#2 0x00000000004062b0 in main (ac=<value optimized out>, av=<value optimized out>) at screen.c:1365

I'm assuming I found the right process, anyhow. There are no zombie clients running, so I can't kill any of those. This is the only process with 'screen' in the name:

millerti 12529 1 0 Nov03 ? 00:00:02 SCREEN

I haven't tried deleting the socket node, but since this seems to be a new problem, I thought it safer if I were to ask for advice before doing something that might make it impossible to find out what happened.

What should I do?


blog (posted by blogspot, Thu 03 Jul 2008 06:49:20 AM UTC)

.screenrc and env variables (posted by Bijoy Thomas, Fri 01 Dec 2006 11:01:59 PM UTC)

Hi all,

I trying to modify an environment variable in my
.screenrc file. I have that variable set in my .bashrc
file but when I launch screen, I want it to be set to
a different value by the .screenrc file. In my .bashrc
file I have

export WORK=~/work

I want this to be ~/work1 .. so I tried

setenv WORK ~/work1 in the .screenrc file but that
dint help.

I also tried using the shell command

shell bash --rcfile .blah, where .blah has
export WORK=~/work1

but then screen complains about the argument count to
the shell command.

Any ideas on how to do this?


SSH Port Forwarding (posted by Larry Ploetz, Wed 29 Nov 2006 12:59:58 AM UTC)

Well, I did a search and didn't come up with anything...

I'm trying to dynamically add port forwarding, local in this case, to an existing ssh session by using screen's paste. I have a file with lines like:

at otherhost stuff "~C-L 12345:thirdhost:22\015"

but when I source it, I see on otherhost:


which is the expected prompt, but no "-L 12345...". Then, when I hit enter or control-c or other similar keys (but not alphanums) I get:

prompt > -L 12345:...
-L: Command not found.

I suspect the "~C" is getting me back to sourcehost, but subsequent stuffing only goes to otherhost's tty.

Any ideas?

- Larry

Mailing List Subscription Address (posted by Tom Purl, Tue 18 Jul 2006 06:16:37 PM UTC)

Here's the link for the mailman page so you can subscribe to this mailing list:

* <>

keypad and .screenrc (posted by Asher Bond, Mon 15 Aug 2005 08:24:31 PM UTC)

I would like to use the numpad in application mode by default. I'm using debian and zsh via ssh and the latest apt-get stable version of ncurses.

Is it possible to set up my .screenrc so that my numpad keys will use home, page up, page down, end, the arrow keys, etc?



Back to the top

Powered by Savane 3.4