bugGNU GRUB - Bugs: bug #35880, grub tries to load...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #35880: grub tries to load $grubdir/locale/en.mo.gz

Submitted by:  Mike GIlbert <floppym>
Submitted on:  Sat 17 Mar 2012 10:04:45 PM UTC
Votes:  85  
 
Category:  Booting Severity:  Major
Priority:  5 - Normal Item Group:  Software Error
Status:  Fixed Privacy:  Public
Assigned to:  None Originator Name:  Mike Gilbert
Open/Closed:  Closed Release: 
Release:  * Bazaar - trunk Reproducibility:  Every Time
Planned Release:  None
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

( Jump to the original submission )

Mon 04 Mar 2013 02:45:11 PM UTC, comment #12: 

For the record, this silly complaint is patched out the very same way at least openSUSE and ALT Linux.

(file #27564)

Michael Shigorin <gvy>
Thu 06 Sep 2012 10:53:05 AM UTC, comment #11: 

Vladimir, I think that this is a kind of odd position to take, honestly.  Userspace gettext falls back silently to untranslated text if translations are unavailable.  I don't see why boot loader translations are so much more important than userspace translations that they require printing an error message; furthermore, surely in cases of doubt similarly-named parts of the GNU system should behave similarly, and therefore GRUB gettext should adopt the behaviour of GNU libc gettext here.

(file #26488)

Colin Watson <cjwatson>
Project Member
Thu 10 May 2012 09:49:11 AM UTC, comment #10: 

IMO the problem is not so much what it try to load but the error message when a locale setting without translation is used.

The complaint about the missing locale is relevant when grub-mkconfig is run - not so much on runtime.

Mads Kiilerich <kiilerix>
Mon 19 Mar 2012 04:09:16 PM UTC, comment #9: 

True.

Perhaps we should change this from a bug to a feature request: add "en" and "en_US" translations.

Mike GIlbert <floppym>
Mon 19 Mar 2012 04:05:15 PM UTC, comment #8: 

The problem here basically is that user requests specifically en_US and not C/POSIX and neither en_US nor en is available.
And actually en_US translation for GRUB would make the sense since currently the translation also specifies date format and by default GRUB uses ISO date.

Vladimir Serbinenko <phcoder>
Project Administrator
Mon 19 Mar 2012 04:00:02 PM UTC, comment #7: 

Right, so your point is that other applications have English translations. Is such a thing in the works for GRUB?

If not, maybe you could just add an empty translation for English to prevent the error message from happening at boot.

Mike GIlbert <floppym>
Mon 19 Mar 2012 03:44:47 PM UTC, comment #6: 

> rather than complaining about a base en translation that will never exist.


phcoder@debian.x201.phnet:16:43:56:~/compile$ ls /usr/share/locale/en/LC_MESSAGES/
clisplow.mo  clisp.mo  gnome-control-center-2.0.mo  gtk30.mo  gtk30-properties.mo  iso_3166_2.mo  lynx.mo

Vladimir Serbinenko <phcoder>
Project Administrator
Sat 17 Mar 2012 11:54:08 PM UTC, comment #5: 

I think the main issue is that the error is misreported; it should tell the user that the en_US dialect is missing, rather than complaining about a base en translation that will never exist.

Mike GIlbert <floppym>
Sat 17 Mar 2012 11:23:54 PM UTC, comment #4: 

Yes, but English is a bit of a special case; the messages are already written in English.

Nobody really cares about quotes in their boot loader.

Mike GIlbert <floppym>
Sat 17 Mar 2012 11:19:27 PM UTC, comment #3: 

It's not created because there is no en.po. But the same holds also for e.g. es.po (Spanish) but we need to give a reason why GRUB isn't in locale language despite being configured for it.

Vladimir Serbinenko <phcoder>
Project Administrator
Sat 17 Mar 2012 11:11:47 PM UTC, comment #2: 

As far as I can tell, en.mo.gz is never created, so attempting to load it will never succeed.

Mike GIlbert <floppym>
Sat 17 Mar 2012 10:12:27 PM UTC, comment #1: 

This is not a bug. "en" locale may also need some translation like handling proper quoting, see en@quot. So not loading it wouldn't be correct.

Vladimir Serbinenko <phcoder>
Project Administrator
Sat 17 Mar 2012 10:04:45 PM UTC, original submission:  

Grub tries to load an English translation if grub-mkconfig is run with an English locale (LANG=en_US.UTF-8).

This causes an error message to briefly displayed before the menu loads on boot up.

This was originally reported downstream at Gentoo Linux.

https://bugs.gentoo.org/show_bug.cgi?id=408599

Mike GIlbert <floppym>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #26488:  gettext_quiet.patch added by cjwatson (612B - text/x-diff)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by gvy (Updated the item)
  • -email is unavailable- added by wfmakowski (Voted in favor of this item)
  • -email is unavailable- added by thewilbur (Voted in favor of this item)
  • -email is unavailable- added by fturco
  • -email is unavailable- added by cjwatson (Updated the item)
  • -email is unavailable- added by kiilerix (Posted a comment)
  • -email is unavailable- added by ridikulus_rat
  • -email is unavailable- added by phcoder (Posted a comment)
  • -email is unavailable- added by floppym (Submitted the item)
  •  

    There are 85 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

     

     

     

    Follow 8 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2013-11-03 phcoder StatusNone => Fixed
        Open/ClosedOpen => Closed
    2013-03-04 gvy Attached File- => Added grub2-fix-locale-en.mo.gz-not-found-error-message.patch, #27564
    2013-01-06 wfmakowski Carbon-Copy- => Added wfmakowski
    2012-12-29 thewilbur Carbon-Copy- => Added thewilbur
    2012-12-08 fturco Carbon-Copy- => Added -email is unavailable-
    2012-09-06 cjwatson Attached File- => Added gettext_quiet.patch, #26488
    2012-04-03 ridikulus_rat Carbon-Copy- => Added ridikulus_rat

    Back to the top


    Powered by Savane 3.9