bugGNU GRUB - Bugs: bug #34965, Fails to boot WinXP (error: no...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #34965: Fails to boot WinXP (error: no such device) when UUIDs match

Submitted by:  Larry Johnson <keepitsimpleeng>
Submitted on:  Thu 01 Dec 2011 09:10:38 PM UTC
 
Category:  Booting Severity:  Major
Priority:  5 - Normal Item Group:  None
Status:  None Privacy:  Public
Assigned to:  None Originator Name:  Larry Johnson
Open/Closed:  Closed Release: 
Release:  * other Reproducibility:  Every Time
Planned Release:  None
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       

 

Fri 02 Dec 2011 04:45:47 PM UTC, comment #2: 

Executing "ls -l" at the grub command line produces a list of the 6 disks (hd0-hd5). The UUIDs match the UUIDS in "blkid" id.

The WinXP partition is on hd5,msdos1 and the Linux partition is on hd0,msdos3.

If I "search --label SATA_01_Csys_10k" grub returns hd5,msdos1, the Windows partition

If I "search --fs-uuid 6258C1DF8F242D86" grub returns hd5,msdos1, the Windows partition

Adding the --no-floppy option to each produces the same result.

In /boot/grub/grub.cfg, the line "set root='(hd2,msdos1)'" is shown.  This partition is "Not a known filesystem"

Grub is installed on hd0.  hd0 is PATA Maxtor 6L300R0 listed in the BIOS as SCSI-1 and is connected to the mainboard by a PCI Raid card, Raid not enabled-to allow PATA drives to be used on SATA mainboard.

hd5 is a WDC WD740GD SATA drive.

After the above tests, I retested GRUB and it inexplicably boot both system properly.

I reviewed /var/log/dpkg.log from 11-26 thru 12-1 and found no grub updates.

I suppose the bug can be closed.

Thanks.

Larry Johnson <keepitsimpleeng>
Thu 01 Dec 2011 10:25:13 PM UTC, comment #1: 

Are you able to see the disk in question if you go to GRUB console and type "ls -l" ?

Vladimir Serbinenko <phcoder>
Project Administrator
Thu 01 Dec 2011 09:10:38 PM UTC, original submission:  

Grub verion 1.99 from Ubuntu x86 10.10 Desktop CD clean install.

After install, grub will not launch Windows, although Windows launches with BIOS boot disk selection.

Verified UUID correct...
root@...:~# blkid
/dev/sda1: TYPE="swap"
/dev/sda2: LABEL="SATA2_01__D" UUID="23181E9787F9E1A6" TYPE="ntfs"
/dev/sda3: LABEL="DRIVE_W" UUID="D71A-96E7" TYPE="vfat"
/dev/sdc1: LABEL="SATA_01_Csys_10k" UUID="6258C1DF8F242D86" TYPE="ntfs"
/dev/sdd1: LABEL="SATA_01_D_10k" UUID="6947F57DE005AA85" TYPE="ntfs"
/dev/sdd5: LABEL="SATA2_01_E" UUID="4BC2AEB11E651F37" TYPE="ntfs"
/dev/sdd6: LABEL="SATA2_01_D_BU_101222" UUID="2D2D0850B3A6BE7B" TYPE="ntfs"
/dev/sdb1: LABEL="SATA2_02_L" UUID="EF0625F841CA9127" TYPE="ntfs"
/dev/sde3: UUID="c713bb8e-f6d3-4269-935e-c9c86804f0a8" TYPE="ext4"
/dev/sde5: LABEL="IDE_01_G" UUID="1989E973D755FDC1" TYPE="ntfs"
/dev/sde6: UUID="15efbdad-ec18-43a9-bd80-6053c13624a7" TYPE="swap"
/dev/sde7: UUID="5c7f6d42-ad53-4a4a-befc-48e2d1594c31" TYPE="ext4"
/dev/sde8: UUID="bfc3f076-462c-4c16-8bd2-509b51ba0e01" TYPE="swap"
/dev/sdf1: LABEL="IDE_02_H" UUID="34709ADA709AA262" TYPE="ntfs"

from /boot/grub/grub.cfg
### BEGIN /etc/grub.d/30_os-prober ###
menuentry "Microsoft Windows XP Professional (on /dev/sdc1)" --class windows --$
        savedefault
        insmod part_msdos
        insmod ntfs
        set root='(hd2,msdos1)'
        search --no-floppy --fs-uuid --set=root 6258C1DF8F242D86
        drivemap -s (hd0) ${root}
        chainloader +1
}
### END /etc/grub.d/30_os-prober ###

tried the workaround @ http://sourceforge.net/apps/mediawiki/bootinfoscript/index.php?title=Boot_Problems:search

Commenting out three lines in /usr/lib/grub/grub-mkconfig_lib (Step 4)

This bricked grub2, booting 11.10 gets "error: no such partition"
and booting Windows gets: "error: invalid signature"

Undoing the changes (using chroot and the LiveCD) and rerunnin update-grub restored the original grub boot process.

ProblemType: Bug
DistroRelease: Ubuntu 11.10
Package: grub-pc 1.99-12ubuntu5
ProcVersionSignature: Ubuntu 3.0.0-13.22-generic 3.0.6
Uname: Linux 3.0.0-13-generic i686
NonfreeKernelModules: fglrx
ApportVersion: 1.23-0ubuntu4
Architecture: i386
Date: Fri Nov 25 11:48:42 2011
InstallationMedia: Ubuntu 11.10 "Oneiric Ocelot" - Release i386 (20111012)
SourcePackage: grub2
UpgradeStatus: No upgrade log present (probably fresh install)

Filed Ubuntu bug https://bugs.launchpad.net/ubuntu/+source/grub2/+bug/896391

Attached: RESULTS.txt from bootinfoscript from http://bootinfoscript.sourceforge.net/

Changes to grub.cfg as a result of workaround

Larry Johnson <keepitsimpleeng>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #24515:  RESULTS.txt added by keepitsimpleeng (21KiB - text/plain)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by phcoder (Posted a comment)
  • -email is unavailable- added by keepitsimpleeng (grub2 bug)
  • -email is unavailable- added by keepitsimpleeng (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

     

     

     

    Follow 4 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2012-06-03 phcoder Open/ClosedOpen => Closed
    2011-12-01 keepitsimpleeng Attached File- => Added 11.10 grub problem.txt, #24516
        Carbon-Copy- => Added keepitsimpleeng
    2011-12-01 keepitsimpleeng Attached File- => Added RESULTS.txt, #24515

    Back to the top


    Powered by Savane 3.9