bugGNU TeXmacs - Bugs: bug #56704, "Look for more fonts"...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #56704: "Look for more fonts" makes TeXmacs crash

Submitted by:  Antoine BOUCHER <elkeo>
Submitted on:  Thu 01 Aug 2019 01:23:39 PM UTC  
 
Category:  Styles Priority:  5 - Normal
Item Group:  Error Status:  In Progress
Privacy:  Public Assigned to:  Denis Raux <denisraux>
Originator Name:  Open/Closed:  Closed
Release:  1.99.11 Release:  1.99.11
Fixed Release:  None Fixed Release: 
Keywords: 

Thu 24 Oct 2019 01:38:37 PM UTC, comment #3: 

No additional comments. It didn't appear on regular windows10 installation.
It's probably due to a corrupted font database.

Denis Raux <denisraux>
Project MemberIn charge of this item.
Tue 22 Oct 2019 12:16:34 PM UTC, comment #2: 

Can you run Texmacs from a command window with the option --delete-font-cache ?
That completely rebuilds the fonts caches, with the original texmacs fonts, additional fonts laying in your  AppData\Romaning\TeXmacs\fonts directory, and the system fonts (you can see with the tool in parameter)

Denis Raux <denisraux>
Project MemberIn charge of this item.
Fri 18 Oct 2019 11:16:33 PM UTC, comment #1: 

I just rechecked on a non-windows computer and everything works fine (looking for fonts indeed takes some time, as the popup message indicates).  I can use any new fonts that were found when relaunching TeXmacs a second time.

Probably something went wrong when trying to save in
$TEXMACS_HOME_PATH/fonts/font-database.scm

Maybe Denis can check what went wrong;
Denis: I put some new fonts for testing in
magix/texmacs/fonts/dafont/fancy-horror

Joris van der Hoeven <vdhoeven>
Project Administrator
Thu 01 Aug 2019 01:23:39 PM UTC, original submission:  

When clicking on the "Look for more fonts" button, TeXmacs searches fonts for a long time (15 mins, making it not responding) and sometimes ends up showing an empty std error message or showing a real error message. If I close the window when the error is empty, the window closes and TeXmacs crashes instantaneously. But if the error shows up text and that I try to close the window, the window re-opens and shows a second error message. When I look at the fonts panel (because TeXmacs can still work), pretty much all my installed fonts show up but I can't use them (they aren't activating) and if I close TeXmacs then re-open it, they disappear. This happens whether the "Advanced font customisation" box is checked or not. I tried reinstalling TeXmacs many times, changing its directory for a folder on my desktop but nothing seems to stop the issue. I'm on Windows 10.

Antoine BOUCHER <elkeo>

 

Attached Files

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by denisraux (Posted a comment)
  • -email is unavailable- added by vdhoeven (Posted a comment)
  • -email is unavailable- added by elkeo (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 8 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2019-10-24 denisraux Open/ClosedOpen => Closed
    2019-10-18 vdhoeven StatusNone => In Progress
        Assigned toNone => denisraux
        ReleaseNone => 1.99.11
    2019-08-01 elkeo Attached File- => Added Annotation@2019-08-01@151237.jpg, #47284
        Attached File- => Added Annotation@2019-08-01@151414.jpg, #47285
        Attached File- => Added Annotation@2019-08-01@151453.jpg, #47286
        Attached File- => Added Annotation@2019-08-01@151535.jpg, #47287

    Back to the top


    Powered by Savane 3.5