bugGNU TeXmacs - Bugs: bug #56583, Failed to make after ./configure

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #56583: Failed to make after ./configure

Submitted by:  Darcy Shen <sadhen>
Submitted on:  Sat 06 Jul 2019 10:52:52 AM UTC  
 
Category:  None Priority:  5 - Normal
Item Group:  None Status:  None
Privacy:  Public Assigned to:  None
Originator Name:  Open/Closed:  Open
Release:  1.99.10 Release:  None
Fixed Release:  None Fixed Release: 
Keywords: 

Wed 10 Jul 2019 01:20:07 PM UTC, comment #2: 

I've also a Qt5 branch waiting to be integrated here: https://github.com/mgubi/texmacs
My current impressio is that changes are minimal and TeXmacs seems to work ok. But keep in mind that is still experimental.

On Mac you need at least Qt 5.13 otherwise some menu (notably the color palettes) will not work properly.

Massimiliano Gubinelli <mgubi>
Project Administrator
Sat 06 Jul 2019 11:46:48 AM UTC, comment #1: 

You are attempting a QT5 build (QT5 is very likely the default on your machine) but it is still experimental for texmacs. Some of the problems you get are addressed in the patch I proposed in #51486 (but it may be outdated by now, I haven't tried it recently).

OTOH, if you want the regular qt4 build, run "export QT_SELECT=qt4" before the configure, and it should go through.

Philippe Joyez <pjoyez>
Project Member
Sat 06 Jul 2019 10:52:52 AM UTC, original submission:  

System: Debian.

Commands:

./configure
make

Error:

g++ -ISystem -ISystem/Boot -ISystem/Classes -ISystem/Files -ISystem/Link -ISystem/Misc -ISystem/Language -IKernel/Abstractions -IKernel/Containers -IKernel/Types -IData/Convert -IData/Drd -IData/History -IData/Observers -IData/Document -IData/String -IData/Tmfs -IData/Tree -IScheme -IGraphics/Bitmap_fonts -IGraphics/Fonts -IGraphics/Gui -IGraphics/Mathematics -IGraphics/Renderer -IGraphics/Handwriting -IGraphics/Types -IGraphics/Pictures -IGraphics/Spacial -IGraphics/Colors -IPlugins -IPlugins/Unix -ITypeset -ITypeset/Bridge -ITypeset/Concat -ITypeset/Page -IEdit -IPlugins -ITexmacs -isystem /usr/include/x86_64-linux-gnu/qt5 -isystem /usr/include/x86_64-linux-gnu/qt5/QtWidgets -isystem /usr/include/x86_64-linux-gnu/qt5/QtGui -isystem /usr/include/x86_64-linux-gnu/qt5/QtCore -isystem /usr/include/libdrm -pipe -O2 -Wall -W -include config.h -DQT_DEPRECATED_WARNINGS -DQT_NO_DEBUG -DQT_WIDGETS_LIB -DQT_GUI_LIB -DQT_CORE_LIB -I. -I/usr/lib/x86_64-linux-gnu/qt5/mkspecs/linux-g++ -D_REENTRANT -DQTTEXMACS -Wall -Wno-return-type -O3 -fexpensive-optimizations -fno-rtti -fno-rtti -c ./Texmacs/Texmacs/texmacs.cpp -o Objects/texmacs.o
In file included from /usr/include/x86_64-linux-gnu/qt5/QtCore/qsharedpointer.h:43:0,
                 from /usr/include/x86_64-linux-gnu/qt5/QtCore/qpointer.h:43,
                 from /usr/include/x86_64-linux-gnu/qt5/QtCore/QPointer:1,
                 from Plugins/Qt/qt_widget.hpp:17,
                 from Plugins/Qt/qt_simple_widget.hpp:18,
                 from Edit/editor.hpp:20,
                 from Texmacs/server.hpp:14,
                 from ./Texmacs/Texmacs/texmacs.cpp:25:
/usr/include/x86_64-linux-gnu/qt5/QtCore/qglobal.h:1162:4: error: #error "You must build your code with position independent code if Qt was built with -reduce-relocations. " "Compile your code with -fPIC (-fPIE is not enough)."
#  error "You must build your code with position independent code if Qt was built with -reduce-relocations. "\
    ^~~~~

Darcy Shen <sadhen>
Project Member

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by mgubi (Posted a comment)
  • -email is unavailable- added by pjoyez (Posted a comment)
  • -email is unavailable- added by sadhen (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    No changes have been made to this item

    Back to the top


    Powered by Savane 3.5