bugGNU Astronomy Utilities - Bugs: bug #55217, --align not working as expected in...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #55217: --align not working as expected in left-hand oriented WCS

Submitted by:  Mohammad Akhlaghi <makhlaghi>
Submitted on:  Thu 13 Dec 2018 01:52:58 AM UTC  
 
Category:  Warp Severity:  3 - Normal
Item Group:  Output not reasonable Status:  Postponed
Privacy:  Public Assigned to:  None
Open/Closed:  Open

Thu 13 Dec 2018 01:52:58 AM UTC, original submission:  

When the input WCS dataset is left-hand oriented (East is to the left of North, what ever direction North has), then the `--align' operator doesn't work as expected.

This problem can be reproduced with a simple mock image:

$ echo "0 25 25 1 2 1 45 0.5 1 5"                    \
       | astmkprof --oversample=1 --mergedsize=49,49 \
                   --output=in.fits
$ astwarp in.fits --flip=0,1 --rotate=20
$ astwarp in_warped.fits --align

The output `in_warped_aligned.fits' will not be aligned with the standard RA/Dec directions (North to the top and East to the left).

However, apparently no information is lost, because after opening `in.fits' and `in_warped_aligned.fits' in ds9 and matching them by their WCS, things seem reasonable. So --align is apparently just failing in finding the wrong rotation, it doesn't look like a lower-level problem (in mixing pixels for example).

Mohammad Akhlaghi <makhlaghi>
Project Administrator

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by makhlaghi (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    No changes have been made to this item

    Back to the top


    Powered by Savane 3.5