bugPSPP - Bugs: bug #51456, PSPP

 
 

bug #51456: PSPP

Submitted by:  None
Submitted on:  Thu 13 Jul 2017 08:49:12 AM UTC  
 
Category:  None Severity:  5 - Average
Status:  None Assigned to:  None
Open/Closed:  Closed Release:  None
Effort:  0.00

Add a New Comment (Rich Markup)
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Sun 16 Jul 2017 06:45:43 PM UTC, comment #5: 

The testbuild from 2017-07-17 should be working again on MSWindows.

The bug can be closed.

Harry Thijssen <unknown_one>
Fri 14 Jul 2017 07:10:35 AM UTC, comment #4: 

Here by a screen dump of the backtrace


Harry Thijssen <unknown_one>
Thu 13 Jul 2017 08:52:37 PM UTC, comment #3: 

When running wine psppire.exe with the 2017-06-26 version the program runs, and I get the messages:

Gtk-Message: Failed to load module "canberra-gtk-module"

(psppire.exe:8): GModule-CRITICAL **: g_module_symbol: assertion 'symbol != NULL' failed
fixme:file:GetLongPathNameW UNC pathname L"\\\\?\\C:\\users\\harry\\Local Settings\\Application Data\\recently-used.xbel"

(psppire.exe:8): GModule-CRITICAL **: g_module_symbol: assertion 'symbol != NULL' failed

(psppire.exe:8): GModule-CRITICAL **: g_module_symbol: assertion 'symbol != NULL' failed

                                                                                                                                                                                                                                           

(psppire.exe:8): GModule-CRITICAL **: g_module_symbol: assertion 'symbol != NULL' failed                                                                                                                                                   
fixme:msvcrt:MSVCRT__wsopen_s : pmode 0x01b6 ignored                                                                                                                                                                                       
fixme:msvcrt:MSVCRT__wsopen_s : pmode 0x01b6 ignored                                                                                                                                                                                       
fixme:msvcrt:MSVCRT__wsopen_s : pmode 0x01b6 ignored                                                                                                                                                                                       

                                                                                                                                                                                                                                           

(psppire.exe:8): GModule-CRITICAL **: g_module_symbol: assertion 'symbol != NULL' failed    

So it looks as if the problems where introduced on 2017-06-27.

Harry Thijssen <unknown_one>
Thu 13 Jul 2017 08:05:53 PM UTC, comment #2: 

When running wine pspp.exe I get:

harry@linux-ra3m:/usr/i686-w64-mingw32/sys-root/mingw/bin> wine pspp.exe
wine: Unhandled stack overflow at address 0x52ed68 (thread 0009), starting debugger...
err:seh:setup_exception_record stack overflow 832 bytes in thread 0009 eip 7bc51d3a esp 00950ff0 stack 0x950000-0x951000-0xb50000

When running wine psppire.exe I get:

harry@linux-ra3m:/usr/i686-w64-mingw32/sys-root/mingw/bin> wine psppire.exe
Gtk-Message: Failed to load module "canberra-gtk-module"

(psppire.exe:8): GModule-CRITICAL **: g_module_symbol: assertion 'symbol != NULL' failed
wine: Unhandled stack overflow at address 0x5b8e31 (thread 0009), starting debugger...
err:seh:setup_exception_record stack overflow 836 bytes in thread 0009 eip 7bc52215 esp 00ce0fec stack 0xce0000-0xce1000-0xee0000

I guess the message about the canberra-gtk-module can be ignored. But there is the same error in pspp as in psppire. I believe the issue is introduced betweem 2017-06-10 and 2017-07-29. Any ideas what this can be?
In the meantime I will try to find out which day the problem started.

Harry Thijssen <unknown_one>
Thu 13 Jul 2017 08:51:26 AM UTC, comment #1: 

I submitted the bug.
email: -email is unavailable-

elias tsolis <estatistics>
Thu 13 Jul 2017 08:49:12 AM UTC, original submission:  

I have a laptop with Windows 10 64bit.
I downloaded the Test versions of PSPP

"2017-06-29-TestBuild and 2017-06-10-TestBuild"

I downloaded both the normal build as well the debug build.
All these PSPP versions crash on windows 10 in my laptop.
While the previous PSPP stable version do not crash, it is running correctly!

Error message was about:

"(gdb) run
Starting program: F:\progs\pspp\bin\psppire.exe
[New Thread 7708.0x14dc]
[New Thread 7708.0x1748]
[New Thread 7708.0x1950]
[New Thread 7708.0x434]
[New Thread 7708.0x5d4]
[New Thread 7708.0x1bb0]
[New Thread 7708.0xc80]
[New Thread 7708.0x168c]
[New Thread 7708.0x1ce0]
[New Thread 7708.0x1d3c]

(psppire.exe:7708): GModule-CRITICAL **: g_module_symbol: assertion 'symbol != NULL' failed

Program received signal SIGSEGV, Segmentation fault.
0x005b8dd8 in rpl_localtime (timep=0x29f8d8) at localtime-buffer.c:38
38      localtime-buffer.c: No such file or directory.
(gdb) cx1x"

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #41200:  Naamloos.png added by unknown_one (91KiB - image/png)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by jmd (Updated the item)
  • -email is unavailable- added by unknown_one (Posted a comment)
  • -email is unavailable- added by estatistics (Posted a comment)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 2 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2017-07-28 jmd Open/ClosedOpen => Closed
    2017-07-14 unknown_one Attached File- => Added Naamloos.png, #41200

    Back to the top


    Powered by Savane 3.6