bugGNU gettext - Bugs: bug #47674, gettext test suite fails with grep...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #47674: gettext test suite fails with grep 2.24

Submitter:  Dominique Leuenberger <dimstar>
Submitted:  Tue 12 Apr 2016 11:16:59 AM UTC
 
Category:  Build Severity:  3 - Normal
Item Group:  None Status:  Not a Bug
Privacy:  Public Assigned to:  ueno
Open/Closed:  Closed
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       No canned response available

 

Fri 13 May 2016 02:52:57 AM UTC, comment #2: 

According to the announcement, I assume this is no longer the case with grep 2.25:
https://lists.gnu.org/archive/html/info-gnu/2016-04/msg00010.html

Daiki Ueno <ueno>
Project Administrator
Wed 13 Apr 2016 01:38:59 AM UTC, comment #1: 

I'd expect it will be fixed once the next version of grep is released, with a fix in gnulib incorporated:
https://lists.gnu.org/archive/html/bug-gnulib/2016-04/msg00009.html

We would better wait it rather than adding a workaround relying on the non portable -a option.

Daiki Ueno <ueno>
Project Administrator
Tue 12 Apr 2016 11:16:59 AM UTC, original submission:  

While running make check using 'grep 2.24', the test suite fails:

[  540s] ============================================================================
[  540s] Testsuite summary for gettext-tools 0.19.6
[  540s] ============================================================================
[  540s] # TOTAL: 408
[  540s] # PASS:  373
[  540s] # SKIP:  27
[  540s] # XFAIL: 0
[  540s] # FAIL:  8
[  540s] # XPASS: 0
[  540s] # ERROR: 0
[  540s] ============================================================================
[  540s] See tests/test-suite.log
[  540s] Please report to -email is unavailable-

The reason is the way grep handles auto-detection of binary files vs pure text files (in case of gettext, we pipe everything)

The easiest solution is to change "grep -v" to "grep -a -v", thus forcing 'text' mode

Dominique Leuenberger <dimstar>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #36956:  gettext-runtime-grep-2.24_2.patch added by None (8KiB - text/x-patch - patch againt 0.19.7 (xgettext-glade-2 test))
file #36902:  gettext-runtime-grep-2.24.patch added by dimstar (8KiB - text/x-patch - Minimal patch to fix test suite with grep 2.24)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by haible (Updated the item)
  • -email is unavailable- added by ueno (Posted a comment)
  • -email is unavailable- added by dimstar (Submitted the item)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

     

     

     

    Follow 7 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-12-12 haible StatusInvalid Not a Bug
    2016-11-27 haible CategoryNone Build
        Assigned toNone ueno
    2016-05-13 ueno StatusNone Invalid
        Open/ClosedOpen Closed
    2016-04-18 None Attached File- Added gettext-runtime-grep-2.24_2.patch, #36956
    2016-04-12 dimstar Attached File- Added gettext-runtime-grep-2.24.patch, #36902

    Back to the top


    Powered by Savane 3.9