bugGNU gettext - Bugs: bug #45620, po-mode does not handle four-part...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #45620: po-mode does not handle four-part version number

Submitted by:  Peter Eisentraut <petere>
Submitted on:  Sat 25 Jul 2015 12:24:09 AM UTC  
 
Category:  PO mode Severity:  3 - Normal
Item Group:  None Status:  Fixed
Privacy:  Public Assigned to:  Daiki Ueno <ueno>
Open/Closed:  Closed

Mon 27 Jul 2015 03:20:06 AM UTC, comment #1: 

Thanks, applied.

Daiki Ueno <ueno>
Project AdministratorIn charge of this item.
Sat 25 Jul 2015 12:24:09 AM UTC, original submission:  

With a four-part version number such as 0.19.5.1, po-validate (and perhaps other things) in po-mode.el fail with

    "'msgfmt' from GNU gettext 0.10.36 or greater is required"

because po-msgfmt-version-check does not handle that version format.

Attached is a patch, but you might want to check whether that handles all version formats that you intend to use.

Peter Eisentraut <petere>

 

Attached Files

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by haible (Updated the item)
  • -email is unavailable- added by ueno (Posted a comment)
  • -email is unavailable- added by petere (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-11-27 haible CategoryNone => PO mode
        Assigned toNone => ueno
    2015-07-27 ueno StatusNone => Fixed
        Open/ClosedOpen => Closed
    2015-07-25 petere Attached File- => Added 0001-po-mode-Fix-to-accept-four-part-msgfmt-version-numbe.patch, #34515

    Back to the top


    Powered by Savane 3.5