bugGNU gettext - Bugs: bug #44925, configure.ac errors in...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #44925: configure.ac errors in gettext-runtime under mingw32

Submitter:  None
Submitted:  Sat 25 Apr 2015 06:23:26 PM UTC
 
Category:  Build Severity:  3 - Normal
Item Group:  None Status:  Duplicate
Privacy:  Public Assigned to:  ueno
Open/Closed:  Closed
* Mandatory Fields

Add a New Comment (Rich Markup)
   

Comment Type & Canned Response:
       No canned response available

 

Sat 25 Apr 2015 11:38:11 PM UTC, comment #2: 

The problem is that build-aux/git-version-gen was mistakenly not included in that version.  That should be fixed in the 0.19.4 release after this commit:
http://git.savannah.gnu.org/cgit/gettext.git/commit/?id=474582b5

Daiki Ueno <ueno>
Project Administrator
Sat 25 Apr 2015 06:24:27 PM UTC, comment #1: 

Apologies, this also happens in gettext-tools, as seen by the attached patch, which I did not mention.

Anonymous
Sat 25 Apr 2015 06:23:26 PM UTC, original submission:  

Dear GNU gettext devs,

I have found that when attempting to cross-compile for mingw32 under debian x86_64, I get the following errors when building getext-0.19.3, as unpacked with dpkg-source -x  on  gettext_0.189.3-2

I get:
CDPATH="${ZSH_VERSION+.}:" && cd . && /bin/bash /home/pcuser/mingw32/deps/gettext-0.19.3/build-aux/missing aclocal-1.14 -I m4 -I ../m4 -I gnulib-m4
sh: 1: ../build-aux/git-version-gen: not found
configure.ac:25: error: AC_INIT should be called with package and version arguments
/usr/share/aclocal-1.14/init.m4:29: AM_INIT_AUTOMAKE is expanded from...
configure.ac:25: the top level
autom4te: /usr/bin/m4 failed with exit status: 1
aclocal-1.14: error: echo failed with exit status: 1
Makefile:1275: recipe for target 'aclocal.m4' failed
make[2]: *** [aclocal.m4] Error 1
make[2]: Leaving directory '/home/pcuser/mingw32/deps/gettext-0.19.3/gettext-runtime'

This seems to stem from the use of AC_INIT in the gettext-runtime subfolder, where no version number is supplied. The attached patch seems to "fix" the problem (and is likely not doing it correctly). I am uncertain if this is the root cause, as I am hardcoding the version number which seems not quite right.

Also, I note that the primary gettext configure.ac does not supply a version number either - I don't understand why this is needed in one and not the other. I assume this is because aclocal is not running on the base configure?

Thanks!

Anonymous

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach Files:
   
   
Comment:
   

Attached Files
file #33786:  gettext-fix-configure-versions added by None (1KiB - application/octet-stream)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -email is unavailable- added by haible (Updated the item)
  • -email is unavailable- added by ueno (Posted a comment)
  •  

    There are 0 votes so far. Votes easily highlight which items people would like to see resolved in priority, independently of the priority of the item set by tracker managers.

    Only logged-in users can vote.

     

     

     

     

    Follow 5 latest changes.

    Date Changed by Updated Field Previous Value => Replaced by
    2016-11-27 haible CategoryNone Build
        Assigned toNone ueno
    2015-04-25 ueno StatusNone Duplicate
        Open/ClosedOpen Closed
    2015-04-25 None Attached File- Added gettext-fix-configure-versions, #33786

    Back to the top


    Powered by Savane 3.9