bugMIT/GNU Scheme - Bugs: bug #42667, 9.2: Edwin still not opening files...


bug #42667: 9.2: Edwin still not opening files on Windows 7.

Submitted by:  Shawn Stovall <corune>
Submitted on:  Wed 02 Jul 2014 07:15:30 PM UTC  
Category: edwinSeverity: 3 - Normal
Priority: 5 - NormalItem Group: Incorrect behavior
Status: NonePrivacy: Public
Assigned to: NoneOriginator Name: 
Open/Closed: Open

Add a New Comment (Rich MarkupRich Markup):

You are not logged in

Please log in, so followups can be emailed to you.


Mon 13 Apr 2015 09:22:21 PM UTC, comment #4:

Thank you. In fact, I found it a while ago. Unfortunately, it does me little good, becuase Release 9.0 will apparently not support the scmutils library (it will neither compile the library source itself nor work with the library compiled using Release 9.2. At least I have been able to get the Mac OS Version to work on my other (Mac) computer. The fact that it seems impossible to use the scmutils library on a Windows machine is very unfortunate, since two interesting books by Sussman and Wisdom rely on the reader being able to use that library.

Ray Artz <rayartz>
Mon 13 Apr 2015 06:35:49 PM UTC, comment #3:


Sat 14 Feb 2015 05:24:58 PM UTC, comment #2:

How can one find Edwin Release 9.0 for Windows? All my attempts to find an earlier release have failed. (This is a VERY irritating problem since there is apparently no way to open an existing file in Edwin under Windows -- at least as applies to Windows 7 and Edwin Release 9.2. It is dissapointing that a long-standing problem has not even been assigned for resolution.)

Ray Artz <rayartz>
Wed 26 Nov 2014 12:38:15 PM UTC, comment #1:

Installing Release 9.0 solves the problem.

Wed 02 Jul 2014 07:15:30 PM UTC, original submission:

There was a persistent problem in release 9.1 on Windows in where Edwin would not open existing files. The same thing seems to be happening now. The only difference I note is when I try to open the tutorial instead of getting the error message: "Internal error: The object #f, passed as the first argument to %record-ref, is not the correct type". I'm now getting: "Internal error: Edwin tutorial is corrupted". I also can't open normal files I'm working on. I type in the path and everything seems to work normally, except the actual text of the file does not load. There are no error messages present for this.

Shawn Stovall <corune>


(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):

No files currently attached


Depends on the following items: None found

Items that depend on this one: None found


Carbon-Copy List
  • -unavailable- added by rayartz (Posted a comment)
  • -unavailable- added by corune (Accidentally deleted myself from the CC list.)

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.


    Please enter the title of George Orwell's famous dystopian book (it's a date):



    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Wed 02 Jul 2014 08:08:50 PM UTCcoruneCarbon-Copy-=>Added -unavailable-
    Wed 02 Jul 2014 08:08:20 PM UTCcoruneCarbon-CopyRemoved 95843=>-

    Back to the top

    Powered by Savane 3.1-cleanup