bugmake - Bugs: bug #41762, VMS not reporting circular...

 
 

bug #41762: VMS not reporting circular dependency dropped.

Submitted by:  John Malmberg <wb8tyw>
Submitted on:  Mon 03 Mar 2014 05:41:04 AM UTC  
 
Severity: 3 - NormalItem Group: Bug
Status: Not A BugPrivacy: Public
Assigned to: NoneOpen/Closed: Closed
Component Version: 4.0Operating System: VMS
Fixed Release: NoneTriage Status: None

Add a New Comment (Rich MarkupRich Markup):
   

You are not logged in

Please log in, so followups can be emailed to you.

 

Mon 08 Sep 2014 01:32:41 AM UTC, comment #4:

Hi John; I'll close this. Thanks.

Paul D. Smith <psmith>
Project Administrator
Tue 04 Mar 2014 05:34:34 AM UTC, comment #3:

I have fixed the VMS port of the test_driver.pl and run_make_tests.pl for this issue. This port has not yet been submitted.

I do not seem to have the ability to mark this bug as closed.

John Malmberg <wb8tyw>
Mon 03 Mar 2014 06:28:43 AM UTC, comment #2:

This has turned out to be a bug in the VMS port of the test harness. Redirecting STDERR on VMS from perl is different than on Unix.

John Malmberg <wb8tyw>
Mon 03 Mar 2014 05:53:49 AM UTC, comment #1:

The features/errors test is also missing a diagnostic message.

It may be the same issue or different. Tying to to this ticket for now.

      • work/features/errors.base Tue Dec 30 23:44:02 2014

--- work/features/errors.log Tue Dec 30 23:44:02 2014
***************

      • 1,5 ****

rm cleanit
rm: cannot remove 'cleanit': no such file or directory
/lcl_root/make/tests/work/features/errors.mk:2: recipe for target 'clean' fail
ed
- make: [clean] Error 1 (ignored)
rm foo
--- 1,4 ----

John Malmberg <wb8tyw>
Mon 03 Mar 2014 05:41:04 AM UTC, original submission:

Test 8 in features/double_colon is failing on VMS.

      • work/features/double_colon.base_8 Tue Dec 30 23:32:06 2014

--- work/features/double_colon.log_8 Tue Dec 30 23:32:06 2014
***************

      • 1,3 ****

ok
- make: Circular d <- d dependency dropped.
oops
--- 1,2 ----

John Malmberg <wb8tyw>

 

(Note: upload size limit is set to 16384 kB, after insertion of the required escape characters.)

Attach File(s):
   
   
Comment:
   

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by psmith (Posted a comment)
  • -unavailable- added by wb8tyw (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 2 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon 08 Sep 2014 01:32:41 AM UTCpsmithStatusNone=>Not A Bug
      Open/ClosedOpen=>Closed

    Back to the top


    Powered by Savane 3.1-cleanup