bugGNU TeXmacs - Bugs: bug #38784, Texmacs not starting in windows 8

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #38784: Texmacs not starting in windows 8

Submitted by:  Archit Gupta <archit90>
Submitted on:  Sat 20 Apr 2013 10:40:46 AM UTC  
 
Category: Windows portPriority: 7 - High
Item Group: ErrorStatus: Fixed
Privacy: PublicAssigned to: Denis Raux <denisraux>
Originator Name: Open/Closed: Closed
Release: Release: None
Fixed Release: NoneFixed Release: 1.0.7.19
Keywords: 

(Jump to the original submission Jump to the original submission)

Thu 15 Aug 2013 01:19:48 PM UTC, comment #11:

Can we close this?

Miguel de Benito <mdbenito>
Project Member
Mon 20 May 2013 03:45:33 PM UTC, comment #10:

I have the same problem here.
This temporary fix works for me:
http://svn.savannah.gnu.org/viewvc/checkout/trunk/src/TeXmacs/progs/kernel/texmacs/tm-plugins.scm?root=texmacs

Carl X. Su <carl_tw>
Fri 03 May 2013 02:43:43 PM UTC, comment #9:

For memories :
we have to look at url complete in url.cpp that crashes when called with 2 url-or imbricated and a url-append 'in factor'.
like <url {c:\;{c:\toto*}}\titi>

We have to make a 'on demand' trace activation before because this function is too much called and prevents texmacs to run normally.

Denis Raux <denisraux>
Project MemberIn charge of this item.
Tue 30 Apr 2013 09:22:58 PM UTC, comment #8:

Actually this bug happens when you have a extra directory c:\Program Files (x86). This is not specific to Windows 8. I don't have one on my system, that why i didn't notice anything.

I uploaded a temporary fix. We have to investigate a bit more. Just download the file
TeXmacs\progs\kernel\texmacs\tm-plugins.scm and replace the current one.
Please let us known if there is side effect.

thanks,
denis

Denis Raux <denisraux>
Project MemberIn charge of this item.
Tue 30 Apr 2013 08:45:57 PM UTC, comment #7:

Thanks François,
Your suggestion works on win 7 (I don't know yet on win 8), where 1.7.0.19 does not launch either (whereas 1.7.0.18 does)

Hélène le Sueur <hlesueur>
Tue 30 Apr 2013 12:28:36 PM UTC, comment #6:

Arg ... this bug tracker is ugly !!!

To :

Francois Poulain <fpoulain>
Project Member
Tue 30 Apr 2013 12:27:14 PM UTC, comment #5:

Oooopss ...
to
-verbatim-
(when #f ;(os-mingw?)

Francois Poulain <fpoulain>
Project Member
Tue 30 Apr 2013 12:26:15 PM UTC, comment #4:

Does it works if you edit the file TeXmacs/progs/kernel/texmacs/tm-plugins.scm, edit the line 422, and change it from
to
?

Francois Poulain <fpoulain>
Project Member
Mon 29 Apr 2013 08:11:56 AM UTC, comment #3:

Unfortunatly, I don't have windows8 yet so i can do the test myself right now.

You can get the available options list by launching ./configure --help in the build environment. The option you are looking for is --enable-console

does windows8 have a compatibility mode for the programs like win7 has ? May be this could help.

Denis

Denis Raux <denisraux>
Project MemberIn charge of this item.
Sat 27 Apr 2013 06:23:23 PM UTC, comment #2:

I rebuilt it using the build environment and so on, and it does not work better

Could you give me the procedure on how to compile with a debug console on please?

Helene

Hélène le Sueur <hlesueur>
Sat 27 Apr 2013 09:50:00 AM UTC, comment #1:

I got the same issue on a fresh install

I could hold it "running" by clicking on the menu tabs and browsing through the menus

I tried to deactivate the experimental tool 'fast environments', and got an error report from Visual C++ runtime library 'Assertion Failed' in file ./System/Classes/url.cpp
See attached file for a screen shot

I reproducibly get this error while browsing the menus, so I assume this is not bound to 'fast environments'

Of course, I soon as I leave the menus TM closes.

Hope this can help

Helene

(file #27958)

Hélène le Sueur <hlesueur>
Sat 20 Apr 2013 10:40:46 AM UTC, original submission:

I am unable to get texmacs to work in windows 8.
upon clicking shortcut, the texmacs window opens for a short time then closes by itself.
I do not know how to debug the problem
So any request for logs etc are welcome

Thanks
Archit

Archit Gupta <archit90>

 

Attached Files
file #27958:  CrashTM-fast-env.JPG added by hlesueur (73kB - image/jpeg)

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by mdbenito (Posted a comment)
  • -unavailable- added by carl_tw (Posted a comment)
  • -unavailable- added by denisraux (Posted a comment)
  • -unavailable- added by hlesueur (Updated the item)
  • -unavailable- added by archit90 (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 7 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sat 19 Oct 2013 12:58:12 PM UTCmdbenitoStatusIn Progress=>Fixed
      Open/ClosedOpen=>Closed
    Thu 15 Aug 2013 01:19:48 PM UTCmdbenitoStatusNone=>In Progress
      Assigned toNone=>denisraux
    Fri 03 May 2013 02:43:43 PM UTCdenisrauxPriority8 - Very high=>7 - High
    Tue 30 Apr 2013 12:26:15 PM UTCfpoulainPriority5 - Normal=>8 - Very high
    Sat 27 Apr 2013 09:50:00 AM UTChlesueurAttached File-=>Added CrashTM-fast-env.JPG, #27958

    Back to the top


    Powered by Savane 3.1-cleanup