bugGNU gettext - Bugs: bug #37925, preserve time stamp for libintl.h...

 
 

You are not allowed to post comments on this tracker with your current authentication level.

bug #37925: preserve time stamp for libintl.h in destination folder

Submitted by:  Andrey <andrey>
Submitted on:  Fri 14 Dec 2012 09:11:55 PM UTC  
 
Category: BuildSeverity: 3 - Normal
Item Group: NoneStatus: Not a Bug
Privacy: PublicAssigned to: Daiki Ueno <ueno>
Open/Closed: Closed

Mon 12 Dec 2016 12:57:08 AM UTC, comment #2:

> After running install target without changing any code libintl.h in declination folder installed with new time without changes This is triggering compilation for other library who include libintl.h


Even if libintl.h has not changed, the libintl.a that is being installed at the same time may have changed. Therefore relinking of the libraries or executables that make use of libintl.a may be needed, but the compiler has no way to know it, because the Makefile rules typically do not have the .a files as dependencies, and AFAIK gcc's dependency mechanism looks at the included .h files, not at the linked .a files.

Therefore, really, the only reliable behaviour is that libintl.h and libintl.a are being considered "new", thus your project gets recompiled.

I guess that's also the reason why the install(1) program does not have an option to skip installation if the contents won't change.

Bruno Haible <haible>
Project Administrator
Fri 08 Mar 2013 09:19:15 AM UTC, comment #1:

I think this is normal behavior of upstream library installation.
You could workaround like:

make install INSTALL="install -p"

Daiki Ueno <ueno>
Project AdministratorIn charge of this item.
Fri 14 Dec 2012 09:11:55 PM UTC, original submission:

After running install target without changing any code libintl.h in
declination folder installed with new time without changes
This is triggering compilation for other library who include libintl.h

Problem can be fixed by modifying installation command line in file gettext-runtime/intl/Makefile.in

From
$(INSTALL_DATA) libintl.h $(DESTDIR)$(includedir)/libintl.h; \
To
$(INSTALL_DATA) -p libintl.h $(DESTDIR)$(includedir)/libintl.h; \

Andrey <andrey>

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by haible (Updated the item)
  • -unavailable- added by ueno (Posted a comment)
  • -unavailable- added by andrey (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 0 encouragements so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 4 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Sun 27 Nov 2016 01:32:05 AM UTChaibleCategoryNone=>Build
      Assigned toNone=>ueno
    Fri 08 Mar 2013 09:19:15 AM UTCuenoStatusNone=>Not a Bug
      Open/ClosedOpen=>Closed

    Back to the top


    Powered by Savane 3.1-cleanup1