bugGNU TeXmacs - Bugs: bug #36037, Shortcuts involving custom...

 
 

You are not allowed to post comments on this tracker with your current authentification level.

bug #36037: Shortcuts involving custom language input methods do not work

Submitted by:  Miguel de Benito <mdbenito>
Submitted on:  Thu 29 Mar 2012 07:57:02 PM UTC  
Votes:  1  
 
Category: EditorPriority: 7 - High
Item Group: ErrorStatus: Wont Fix
Privacy: PublicAssigned to: Joris van der Hoeven <vdhoeven>
Originator Name: Open/Closed: Closed
Release: Release: None
Fixed Release: NoneFixed Release: 
Keywords: 

Mon 25 Nov 2013 10:03:05 PM UTC, comment #2:

In order to avoid this kind of problems, I introduced various equivalent shortcuts for the modifier keys. For instance, Control is equivalent to Escape Escape, so Escape Escape Alt-n should do the trick for you. If not, then please reopen the bug. If you think that more prominent explanations should be put in the manual, then please let me know. Of course, adding a few keyboard layout specific shortcuts does not necessary harm either. However, things might quickly become quite complex.

Joris van der Hoeven <vdhoeven>
Project AdministratorIn charge of this item.
Thu 29 Mar 2012 07:59:35 PM UTC, comment #1:

Update: The X11 version has a similar problem. Maybe it would be easier to just redefine the kbd-maps depending on the locale?

Miguel de Benito <mdbenito>
Project Member
Thu 29 Mar 2012 07:57:02 PM UTC, original submission:

Meaning: CTRL+~ won't work under MacOS if the key ~ is obtained via a combination of modifier keys. This is the case with a german keyboard.

To reproduce (in MacOS), choose a german layout for the keyboard and native look and feel for the TM interface. Open a document, add a formula and type a character. Select it and try to add a tilde above using the default shortcut: CTRL+~. With this layout this means pressing CTRL+ALT+n. Nothing happens

The problem is that the only way to obtain a tilde is through QTMWidget::inputMethodEvent() which is never getting the event, because it has an additional modifier, the CTRL key, so it is filtered inside QTMWidget::keyPressEvent() and sent as C-A-n to TeXmacs.

I see no easy solution, other than changing the shortcuts because

  • QInputContext does not provide a list of captured keys and their translations
  • It cannot be asked to process some key combination (or I don't know how)
  • Even if it could, the reasonable place to do it would be after TeXmacs has failed to find a valid action for some shortcut, and at that point we are far, far away from keyPressEvent()

Ideas?

Miguel de Benito <mdbenito>
Project Member

 

No files currently attached

 

Depends on the following items: None found

Items that depend on this one: None found

 

Carbon-Copy List
  • -unavailable- added by vdhoeven (Posted a comment)
  • -unavailable- added by sadhen (Voted in favor of this item)
  • -unavailable- added by mdbenito (Submitted the item)
  •  

    Do you think this task is very important?
    If so, you can click here to add your encouragement to it.
    This task has 1 encouragement so far.

    Only logged-in users can vote.

     

    Please enter the title of George Orwell's famous dystopian book (it's a date):

     

     

    Follow 6 latest changes.

    Date Changed By Updated Field Previous Value => Replaced By
    Mon 25 Nov 2013 10:03:05 PM UTCvdhoevenStatusConfirmed=>Wont Fix
      Assigned toNone=>vdhoeven
      Open/ClosedOpen=>Closed
    Thu 24 Jan 2013 10:52:39 AM UTCsadhenCarbon-Copy-=>Added sadhen
    Thu 29 Mar 2012 07:59:35 PM UTCmdbenitoCategoryQt port=>Editor
      Priority5 - Normal=>7 - High

    Back to the top


    Powered by Savane 3.1-cleanup